summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-07-12 03:00:07 +0200
committerKenjiTakahashi2015-07-12 03:00:07 +0200
commitddcf1023503cf412c677675e3396a0843f2b5c07 (patch)
tree61f809212432d48bd88d4fef408618027581a48c
downloadaur-ddcf1023503cf412c677675e3396a0843f2b5c07.tar.gz
3.1.4-1: Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD57
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d145c50ee5d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = radium
+ pkgdesc = A graphical music editor. A next generation tracker.
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = http://users.notam02.no/~kjetism/radium/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = python2
+ depends = libxaw
+ depends = libsndfile
+ depends = libsamplerate
+ depends = liblrdf
+ depends = qt4
+ depends = libxkbfile
+ depends = glu
+ depends = speex
+ depends = fftw
+ depends = jack
+ depends = libxinerama
+ depends = libxcursor
+ options = !strip
+ source = https://github.com/kmatheussen/radium/archive/3.1.4.tar.gz
+ md5sums = 0bb481835ebdc14c542839e4e66dc22b
+
+pkgname = radium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..648eae4f7b26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+
+# NOTICE: This needs Steinberg VST Audio Plug-Ins SDK in ~/SDKs to work.
+# It can obtained like this:
+# 1. curl -LO http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip
+# 2. unzip vstsdk360_22_11_2013_build_100.zip
+# 3. mkdir -p ~/SDKs/vstsdk2.4
+# 4. cp -va "VST3 SDK/." ~/SDKs/vstsdk2.4
+
+pkgname=radium
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="A graphical music editor. A next generation tracker."
+arch=('i686' 'x86_64')
+url="http://users.notam02.no/~kjetism/radium/"
+license=('GPL')
+depends=(
+ 'python2'
+ 'libxaw'
+ 'libsndfile'
+ 'libsamplerate'
+ 'liblrdf'
+ 'qt4'
+ 'libxkbfile'
+ 'glu'
+ 'speex'
+ 'fftw'
+ 'jack'
+ 'libxinerama'
+ 'libxcursor'
+)
+makedepends=(
+ 'cmake'
+)
+options=(!strip)
+source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('0bb481835ebdc14c542839e4e66dc22b')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make packages
+ BUILDTYPE=RELEASE ./build_linux.sh
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ # Remove objects created during packages compilation.
+ rm -rf "bin/packages"
+
+ mkdir -p "${pkgdir}/opt/radium"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -va "bin/." "${pkgdir}/opt/radium/"
+ ln -s "${pkgdir}/opt/radium/radium" "${pkgdir}/usr/bin/radium"
+}
+
+# vim:set ts=4 sw=4 et: