summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-10-30 17:14:16 +0100
committerJakob Gahde2016-10-30 17:14:16 +0100
commitee89005076cc5b0be180dfc620b63f90becc5ea9 (patch)
treed2aa1beb7c21017b509aac3be05bdc8e24060dc3
parentdbd7b0fc5338da6fab2719424ee0329ab43393ca (diff)
downloadaur-ee89005076cc5b0be180dfc620b63f90becc5ea9.tar.gz
radium 4.2.3-1: New version
The libbfd patch is no longer necessary now
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
-rw-r--r--reenable-libbfd-workaround.patch14
-rw-r--r--use-system-vstsdk.patch22
4 files changed, 22 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b949588abd0d..5a31676aed8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 29 22:27:18 UTC 2016
+# Sun Oct 30 16:13:22 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 4.1.6
- pkgrel = 2
+ pkgver = 4.2.3
+ pkgrel = 1
url = http://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
@@ -30,18 +30,16 @@ pkgbase = radium
depends = libxinerama
depends = libxcursor
options = !strip
- source = https://github.com/kmatheussen/radium/archive/4.1.6.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/4.2.3.tar.gz
source = faust-accept-clang-390.patch
source = dont-empty-qt-library-paths.patch
- source = reenable-libbfd-workaround.patch
source = use-gcc5-for-pluginhost.patch
source = use-system-vstsdk.patch
- md5sums = 538cb0ffab64719bbda03b1c434448e3
+ md5sums = 3fa66475f7dd73c6ad863bc2da16e5f3
md5sums = 9c72bd466ead73e36b0c2d4297d76870
md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
- md5sums = 74ea7a54f0e358035a7f0cc7baf54b6e
md5sums = 9c19006defeef7e317ec23ed8eae1b72
- md5sums = a634357218872c0502202d3c738b5a9d
+ md5sums = 661c15bc037131c1ad8f8f11d3bc957f
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 23f29f9dde75..60a313e05443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=4.1.6
-pkgrel=2
+pkgver=4.2.3
+pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
url="http://users.notam02.no/~kjetism/radium/"
@@ -37,15 +37,13 @@ options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"faust-accept-clang-390.patch"
"dont-empty-qt-library-paths.patch"
- "reenable-libbfd-workaround.patch"
"use-gcc5-for-pluginhost.patch"
"use-system-vstsdk.patch")
-md5sums=('538cb0ffab64719bbda03b1c434448e3'
+md5sums=('3fa66475f7dd73c6ad863bc2da16e5f3'
'9c72bd466ead73e36b0c2d4297d76870'
'77c202bc0a36562eb7b805ad6b7a85b3'
- '74ea7a54f0e358035a7f0cc7baf54b6e'
'9c19006defeef7e317ec23ed8eae1b72'
- 'a634357218872c0502202d3c738b5a9d')
+ '661c15bc037131c1ad8f8f11d3bc957f')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -56,12 +54,11 @@ prepare() {
# Fix QT_QPA_PLATFORM_PLUGIN_PATH problem
patch -Np1 < "${srcdir}/dont-empty-qt-library-paths.patch"
- # See https://github.com/kmatheussen/radium/commit/22be69fd24235cafb5878692d574d500f843c911#commitcomment-17394610
- patch -Np1 < "${srcdir}/reenable-libbfd-workaround.patch"
# Some parts of JUCE that Radium uses depend on unstandardized behaviour
# specific to GCC5, so they don't compile with Arch's regular GCC6 and we
# have to switch back manually
patch -Np1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+
# Use the VST SDK from steinberg-vst36, so the user doesn't have to
# manually put it into his home directory
patch -Np1 < "${srcdir}/use-system-vstsdk.patch"
diff --git a/reenable-libbfd-workaround.patch b/reenable-libbfd-workaround.patch
deleted file mode 100644
index d45eeaeeb555..000000000000
--- a/reenable-libbfd-workaround.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -aur package.pristine/crashreporter/crashreporter_posix.c package.new/crashreporter/crashreporter_posix.c
---- package.pristine/crashreporter/crashreporter_posix.c 2016-06-05 23:57:15.720344670 +0200
-+++ package.new/crashreporter/crashreporter_posix.c 2016-06-05 23:57:33.723548061 +0200
-@@ -28,8 +28,8 @@
- #include <stdio.h>
-
-
--//#define PACKAGE 1 // workaround for bug in libbfd
--//#define PACKAGE_VERSION 1 // workaround for bug in libbfd
-+#define PACKAGE 1 // workaround for bug in libbfd
-+#define PACKAGE_VERSION 1 // workaround for bug in libbfd
- #include "backtrace-symbols.c"
-
- #elif defined(FOR_MACOSX)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index e8a496d802ca..83f906bdba98 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,18 +1,18 @@
diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
---- package.pristine/Makefile.Qt 2016-10-29 12:36:00.479600104 +0200
-+++ package.new/Makefile.Qt 2016-10-29 12:38:36.228464209 +0200
-@@ -190,7 +190,7 @@
+--- package.pristine/Makefile.Qt 2016-10-30 16:03:25.260604684 +0100
++++ package.new/Makefile.Qt 2016-10-30 16:05:44.299544309 +0100
+@@ -192,7 +192,7 @@
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
--COMMONOPT = -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I${HOME}/SDKs/vstsdk2.4 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
-+COMMONOPT = -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
+-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I${HOME}/SDKs/vstsdk2.4 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
ifeq ($(RADIUM_QT_VERSION),5)
COMMONOPT += -DUSE_QT5
diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/check_dependencies.sh
---- package.pristine/check_dependencies.sh 2016-10-29 12:36:00.136269274 +0200
-+++ package.new/check_dependencies.sh 2016-10-29 12:36:53.429214014 +0200
+--- package.pristine/check_dependencies.sh 2016-10-30 16:03:25.373937152 +0100
++++ package.new/check_dependencies.sh 2016-10-30 16:06:12.332664001 +0100
@@ -127,8 +127,8 @@
exit 5
fi
@@ -25,14 +25,14 @@ diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/ch
exit 5
fi
diff -aur --no-dereference package.pristine/pluginhost/Builds/Linux/Makefile package.new/pluginhost/Builds/Linux/Makefile
---- package.pristine/pluginhost/Builds/Linux/Makefile 2016-10-29 12:36:00.166269054 +0200
-+++ package.new/pluginhost/Builds/Linux/Makefile 2016-10-29 12:38:05.555354633 +0200
+--- package.pristine/pluginhost/Builds/Linux/Makefile 2016-10-30 16:03:25.383937076 +0100
++++ package.new/pluginhost/Builds/Linux/Makefile 2016-10-30 16:05:19.869730485 +0100
@@ -38,7 +38,7 @@
TARGET_ARCH := -march=native
endif
-- CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4
-+ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I /usr/include/vst36
+- CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
++ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I /usr/include/vst36 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
CFLAGS += $(CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O3 -I../../../Qt `cat ../../../flagopts.opt`
CXXFLAGS += $(CFLAGS) -std=c++11
LDFLAGS += $(TARGET_ARCH) -L$(BINDIR) -L$(LIBDIR) -L/usr/X11R6/lib/ -lX11 -lXext -lXinerama -lasound -ldl -lfreetype -lpthread -lrt