summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2021-07-06 20:48:36 +0100
committerTeteros2021-07-06 20:48:36 +0100
commitf5b72b61d32601e6c442ebf745ed5c79f1fd6b46 (patch)
tree384d10ef714e35ef8802a9e2a477e63f0a98df17
parentbcc5f19d0e98f96236ab68c683e9e5fff27eda36 (diff)
downloadaur-f5b72b61d32601e6c442ebf745ed5c79f1fd6b46.tar.gz
6.9.82-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD15
-rw-r--r--faust-buildfix.patch11
-rw-r--r--faust_add_include.patch10
-rw-r--r--fix-faust-llvm12-gettypebyname.patch26
-rw-r--r--fix-faust-llvm12.patch10
6 files changed, 50 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf801abbe548..8ff3432e6d8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 6.9.72
+ pkgver = 6.9.82
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = x86_64
@@ -39,14 +39,13 @@ pkgbase = radium
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
optdepends = vst-plugins: more plugins
options = !strip
- source = radium-6.9.72.tar.gz::https://github.com/kmatheussen/radium/archive/6.9.72.tar.gz
+ source = radium-6.9.82.tar.gz::https://github.com/kmatheussen/radium/archive/6.9.82.tar.gz
source = add-vstsdk-location-var.patch
- source = faust_add_include.patch
- source = faust-buildfix.patch
- sha256sums = 8e07f83ef89ea16a5ea131c67f8559293a38353bbd71f26f9510c1c01e2b2b44
+ source = fix-faust-llvm12.patch
+ source = fix-faust-llvm12-gettypebyname.patch
+ sha256sums = cb233e1178ab8ffdf6158e532a978dd0fbc86e50a7f9f639a076b3adae233ed6
sha256sums = 8d66045d1a927df67670d2ce0855b246614f2969105bd6c4b78a1fcfd971cc9c
- sha256sums = 69b762b908d30ce78f0e289b39b77c0d56888d000f440169ab86e63bc0a15430
- sha256sums = 857c06b9163a42f38364aa54acbdb12a2d3419e5a200eb31e08db84fc6a342b7
+ sha256sums = 8890f30d7afd2e6e2713d19243354b57e859d20e63ba8c6c8579b754900c6f9f
+ sha256sums = 363d3776bada0c4c74ad43388a6ade503670c88a41c144522f960188ee9e1d37
pkgname = radium
-
diff --git a/PKGBUILD b/PKGBUILD
index 809811f04d0b..ae797b94d29e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=6.9.72
+pkgver=6.9.82
pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
@@ -51,12 +51,12 @@ optdepends=(
options=(!strip)
source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
add-vstsdk-location-var.patch
- faust_add_include.patch faust-buildfix.patch
+ fix-faust-llvm12.patch fix-faust-llvm12-gettypebyname.patch
)
-sha256sums=('8e07f83ef89ea16a5ea131c67f8559293a38353bbd71f26f9510c1c01e2b2b44'
+sha256sums=('cb233e1178ab8ffdf6158e532a978dd0fbc86e50a7f9f639a076b3adae233ed6'
'8d66045d1a927df67670d2ce0855b246614f2969105bd6c4b78a1fcfd971cc9c'
- '69b762b908d30ce78f0e289b39b77c0d56888d000f440169ab86e63bc0a15430'
- '857c06b9163a42f38364aa54acbdb12a2d3419e5a200eb31e08db84fc6a342b7')
+ '8890f30d7afd2e6e2713d19243354b57e859d20e63ba8c6c8579b754900c6f9f'
+ '363d3776bada0c4c74ad43388a6ade503670c88a41c144522f960188ee9e1d37')
prepare() {
cd radium-$pkgver
@@ -64,9 +64,8 @@ prepare() {
# Add VST2SDK env var so we can use VST2 headers from steinberg-vst36 in AUR
patch -p1 < "$srcdir/add-vstsdk-location-var.patch"
- # https://github.com/kmatheussen/radium/pull/1343
- cp "$srcdir/faust_add_include.patch" bin/packages
- patch -p1 < "$srcdir/faust-buildfix.patch"
+ cp "$srcdir/fix-faust-llvm12-gettypebyname.patch" bin/packages
+ patch -p0 < "$srcdir/fix-faust-llvm12.patch"
# This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package
# !! NOTE TO LMMS USERS !!
diff --git a/faust-buildfix.patch b/faust-buildfix.patch
deleted file mode 100644
index f94c724351c1..000000000000
--- a/faust-buildfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur --no-dereference '--exclude=.git' radium-6.9.72.old/bin/packages/build.sh radium-6.9.72.new/bin/packages/build.sh
---- radium-6.9.72.old/bin/packages/build.sh 2021-05-12 12:22:43.000000000 +0100
-+++ radium-6.9.72.new/bin/packages/build.sh 2021-05-17 21:09:20.161588109 +0100
-@@ -103,6 +103,7 @@
- patch -p0 <../faust_nollvm.patch
- fi
- patch -p1 <../faust_llvm_fix.patch
-+ patch -p0 <../faust_add_include.patch
- VERBOSE=1 CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS" CMAKEOPT="-DCMAKE_BUILD_TYPE=Release -DSELF_CONTAINED_LIBRARY=on -DCMAKE_CXX_COMPILER=`which $DASCXX` -DCMAKE_C_COMPILER=`which $DASCC`" make most
- cd ..
- }
diff --git a/faust_add_include.patch b/faust_add_include.patch
deleted file mode 100644
index d23989c2243d..000000000000
--- a/faust_add_include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- architecture/faust/gui/JSONUI.h~ 2020-12-23 21:09:06.000000000 +0000
-+++ architecture/faust/gui/JSONUI.h 2021-05-17 21:03:09.597254660 +0100
-@@ -32,6 +32,7 @@
- #include <iomanip>
- #include <sstream>
- #include <algorithm>
-+#include <limits>
-
- #include "faust/gui/UI.h"
- #include "faust/gui/PathBuilder.h"
diff --git a/fix-faust-llvm12-gettypebyname.patch b/fix-faust-llvm12-gettypebyname.patch
new file mode 100644
index 000000000000..aa77f9853b2f
--- /dev/null
+++ b/fix-faust-llvm12-gettypebyname.patch
@@ -0,0 +1,26 @@
+--- compiler/generator/llvm/llvm_instructions.hh~ 2020-12-23 21:09:06.000000000 +0000
++++ compiler/generator/llvm/llvm_instructions.hh 2021-07-06 18:35:53.832423033 +0100
+@@ -170,7 +170,11 @@
+ LLVMType getStructType(const string& name, const LLVMVecTypes& types)
+ {
+ // We want to have a unique creation for struct types, so check if the given type has already been created
++ #if defined(LLVM_120)
++ StructType* struct_type = StructType::getTypeByName(fModule->getContext(), name);
++ #else
+ StructType* struct_type = fModule->getTypeByName(name);
++ #endif
+ if (!struct_type) {
+ struct_type = StructType::create(fModule->getContext(), name);
+ // Create "packed" struct type to match the size of C++ "packed" defined ones
+@@ -191,7 +195,11 @@
+ if (basic_typed) {
+ return fTypeMap[basic_typed->fType];
+ } else if (named_typed) {
++ #if defined(LLVM_120)
++ LLVMType type = StructType::getTypeByName(fModule->getContext(), "struct.dsp" + named_typed->fName);
++ #else
+ LLVMType type = fModule->getTypeByName("struct.dsp" + named_typed->fName);
++ #endif
+ // Subcontainer type (RWTable...)
+ return (type) ? getTyPtr(type) : convertFIRType(named_typed->fType);
+ } else if (array_typed) {
diff --git a/fix-faust-llvm12.patch b/fix-faust-llvm12.patch
new file mode 100644
index 000000000000..bf158fc14caf
--- /dev/null
+++ b/fix-faust-llvm12.patch
@@ -0,0 +1,10 @@
+--- bin/packages/build.sh~ 2021-07-06 19:29:31.940048964 +0100
++++ bin/packages/build.sh 2021-07-06 19:29:04.396551247 +0100
+@@ -104,6 +104,7 @@
+ fi
+ patch -p1 <../faust_llvm_fix.patch
+ patch -p0 <../faust_add_include.patch
++ patch -p0 <../fix-faust-llvm12-gettypebyname.patch
+ VERBOSE=1 CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS" CMAKEOPT="-DCMAKE_BUILD_TYPE=Release -DSELF_CONTAINED_LIBRARY=on -DCMAKE_CXX_COMPILER=`which $DASCXX` -DCMAKE_C_COMPILER=`which $DASCC`" make most
+ cd ..
+ }