summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2020-11-14 18:03:45 +0000
committerTeteros2020-11-14 18:03:45 +0000
commitf74176eaecf893b4c0d643ae482c10b874f4e384 (patch)
tree04dbf8559dbc416b91968881ecf2eb1a82358864
parenteebc4592fe8295e9e783b1868c9976e4d2279e57 (diff)
downloadaur-f74176eaecf893b4c0d643ae482c10b874f4e384.tar.gz
6.5.77-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
-rw-r--r--downgrade-gcc-libpd.patch12
-rw-r--r--use-updated-faust.patch21
5 files changed, 62 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59939da87921..79d00388d3eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 6.5.73
+ pkgver = 6.5.77
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = x86_64
groups = pro-audio
license = GPL2
makedepends = boost
- makedepends = clang
makedepends = cmake
+ makedepends = gcc9
makedepends = ladspa
makedepends = libxcursor
makedepends = libxinerama
@@ -41,9 +41,15 @@ pkgbase = radium
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
optdepends = vst-plugins: more plugins
options = !strip
- source = radium-6.5.73.tar.gz::https://github.com/kmatheussen/radium/archive/6.5.73.tar.gz
+ source = radium-6.5.77.tar.gz::https://github.com/kmatheussen/radium/archive/6.5.77.tar.gz
+ source = https://github.com/grame-cncm/faust/releases/download/2.27.2/faust-2.27.2.tar.gz
+ source = downgrade-gcc-libpd.patch
+ source = use-updated-faust.patch
source = add-vstsdk-location-var.patch
- sha256sums = afde359439b579045f61eda264fe6351cd1ebfeefb6b630352770ce8649808e4
+ sha256sums = e92c2bfd4331587098bad32e8f0be45afc81f7b4703ed9615f9a9788f57cb223
+ sha256sums = c9b21de69253d5a02a779c2eed74491fc62209d86c24724b429f68098191c39c
+ sha256sums = 88d5a8d2d8074f7993e6fd8bafc84355bf0d1bb6405b391caa3d94f23755c1a0
+ sha256sums = 8e6865eff42e0d1797a363f3ce6debfcdeab3aa0a4700f1bbca47916735ea8fd
sha256sums = 2466b88e345c48be43a835ee0001aac55189ce74b4181d3c4275e459089e7ccc
pkgname = radium
diff --git a/.gitignore b/.gitignore
index aabc5d3e2544..aa52232fbb6e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+.ccls-cache
*.tar.*
*.log
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 58663adc2252..8f126f6c2c6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=6.5.73
+pkgver=6.5.77
pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
@@ -33,8 +33,8 @@ depends=(
)
makedepends=(
boost
- clang
cmake
+ gcc9
ladspa
libxcursor
libxinerama
@@ -51,8 +51,16 @@ optdepends=(
'vst-plugins: more plugins'
)
options=(!strip)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz" add-vstsdk-location-var.patch)
-sha256sums=('afde359439b579045f61eda264fe6351cd1ebfeefb6b630352770ce8649808e4'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
+ "https://github.com/grame-cncm/faust/releases/download/2.27.2/faust-2.27.2.tar.gz"
+ downgrade-gcc-libpd.patch
+ use-updated-faust.patch
+ add-vstsdk-location-var.patch
+)
+sha256sums=('e92c2bfd4331587098bad32e8f0be45afc81f7b4703ed9615f9a9788f57cb223'
+ 'c9b21de69253d5a02a779c2eed74491fc62209d86c24724b429f68098191c39c'
+ '88d5a8d2d8074f7993e6fd8bafc84355bf0d1bb6405b391caa3d94f23755c1a0'
+ '8e6865eff42e0d1797a363f3ce6debfcdeab3aa0a4700f1bbca47916735ea8fd'
'2466b88e345c48be43a835ee0001aac55189ce74b4181d3c4275e459089e7ccc')
prepare() {
@@ -61,6 +69,12 @@ prepare() {
# Add VST2SDK env var so we can use VST2 headers from steinberg-vst36 in AUR
patch -p1 < "$srcdir/add-vstsdk-location-var.patch"
+ # https://github.com/kmatheussen/radium/issues/1298
+ patch -p1 < "$srcdir/downgrade-gcc-libpd.patch"
+
+ # https://github.com/kmatheussen/radium/pull/1299
+ patch -p1 < "$srcdir/use-updated-faust.patch"
+
# This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package
# !! NOTE TO LMMS USERS !!
# !! Comment next line out if you have LMMS installed as it already comes with their own version of Calf plugins !!
diff --git a/downgrade-gcc-libpd.patch b/downgrade-gcc-libpd.patch
new file mode 100644
index 000000000000..a5f603eea7c3
--- /dev/null
+++ b/downgrade-gcc-libpd.patch
@@ -0,0 +1,12 @@
+diff -aur --no-dereference '--exclude=.git' radium-6.5.76.pristine/bin/packages/build.sh radium-6.5.76.new/bin/packages/build.sh
+--- radium-6.5.76.pristine/bin/packages/build.sh 2020-11-13 13:20:36.000000000 +0000
++++ radium-6.5.76.new/bin/packages/build.sh 2020-11-14 16:45:00.047753365 +0000
+@@ -133,7 +133,7 @@
+ sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
+ sed -i 's/k_cext$//' make.scm
+ sed -i 's/oscx //' make.scm
+-sed -i 's/gcc -O3/clang -Wno-return-type -O3/' make.scm
++sed -i 's/gcc/gcc-9/' make.scm
+ make clean
+ make -j`nproc`
+ cd ..
diff --git a/use-updated-faust.patch b/use-updated-faust.patch
new file mode 100644
index 000000000000..1cf9ae20114f
--- /dev/null
+++ b/use-updated-faust.patch
@@ -0,0 +1,21 @@
+diff -aur --no-dereference '--exclude=.git' radium-6.5.76.old/bin/packages/build.sh radium-6.5.76/bin/packages/build.sh
+--- radium-6.5.76.old/bin/packages/build.sh 2020-11-14 17:18:13.886659457 +0000
++++ radium-6.5.76/bin/packages/build.sh 2020-11-14 17:19:39.956981712 +0000
+@@ -91,16 +91,9 @@
+
+
+ rm -fr faust
+-tar xvzf faust-master-dev-2019-12-22.tar.gz
+-mv faust-master-dev faust
++mv ../../../faust-2.27.2 faust
+ cd faust
+-tar xvzf ../faustlibraries-2019-12-22.tar.gz
+-rm -fr libraries
+-mv faustlibraries-master libraries
+ patch -p0 <../faust.patch
+-patch -p1 <../faust_setlocale.patch
+-patch -p0 <../faust_svgfix.patch
+-patch -p1 <../faust_HTTPDServer.patch
+ if env |grep INCLUDE_FAUSTDEV_BUT_NOT_LLVM ; then
+ patch -p0 <../faust_nollvm.patch
+ fi