summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-08-08 00:03:39 +0200
committerChristopher Arndt2023-08-08 00:03:39 +0200
commitb6b05cabff4fdc0258ef73a8804a98db384a2430 (patch)
tree683d4f27d015f3dfe266b8993978e1c84f3872c0
downloadaur-b6b05cabff4fdc0258ef73a8804a98db384a2430.tar.gz
Add new VCS package radium-git
-rw-r--r--.SRCINFO77
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD147
-rw-r--r--build_linux_common.patch11
-rw-r--r--radium.install11
5 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47fc325ceb6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,77 @@
+pkgbase = radium-git
+ pkgdesc = A graphical music editor. A next generation tracker.
+ pkgver = 7.1.92.r7.ge115ad6
+ pkgrel = 1
+ url = https://users.notam02.no/~kjetism/radium/
+ install = radium.install
+ arch = x86_64
+ groups = ladspa-host
+ groups = pro-audio
+ groups = vst-host
+ groups = vst3-host
+ license = GPL2
+ makedepends = boost
+ makedepends = cmake
+ makedepends = libxcursor
+ makedepends = libxinerama
+ makedepends = libxkbfile
+ makedepends = libxrandr
+ makedepends = llvm
+ makedepends = qt5-tools
+ makedepends = vst2sdk
+ depends = alsa-lib
+ depends = binutils
+ depends = desktop-file-utils
+ depends = fftw
+ depends = glib2
+ depends = glu
+ depends = gmp
+ depends = gsfonts
+ depends = guile
+ depends = hicolor-icon-theme
+ depends = jack
+ depends = ladspa
+ depends = libatomic_ops
+ depends = liblo
+ depends = liblrdf
+ depends = libmicrohttpd
+ depends = libmpc
+ depends = libmpc
+ depends = libogg
+ depends = libsamplerate
+ depends = libsndfile
+ depends = libvorbis
+ depends = libxkbfile
+ depends = mpfr
+ depends = ncurses
+ depends = openssl
+ depends = openssl
+ depends = python2
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-webkit
+ depends = qt5-x11extras
+ depends = speex
+ depends = swh-plugins
+ depends = tk
+ depends = ttf-bitstream-vera
+ depends = ttf-croscore
+ depends = ttf-lato
+ depends = xcb-util-keysyms
+ depends = xorg-util-macros
+ optdepends = new-session-manager: for session management
+ optdepends = calf-ladspa: default chorus plugin used in new file templates
+ optdepends = ladspa-plugins: package group for plugins normally included in binary releases
+ optdepends = vst-plugins: more plugins
+ provides = radium-git
+ provides = ladspa-host
+ provides = vst-host
+ provides = vst3-host
+ conflicts = radium
+ options = !strip
+ source = git+https://github.com/kmatheussen/radium
+ source = build_linux_common.patch
+ sha256sums = SKIP
+ sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
+
+pkgname = radium-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d2ea4add3812
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+radium/
+radium-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a49a9f6527d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,147 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: nyx eles
+# Contributor: yustin <#archlinux-proaudio@libera.chat>
+# Contributor: Teteros <teteros at teknik dot io>
+# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+
+_pkgname=radium
+pkgname=$_pkgname-git
+pkgver=7.1.92.r7.ge115ad6
+pkgrel=1
+pkgdesc='A graphical music editor. A next generation tracker.'
+arch=(x86_64)
+url='https://users.notam02.no/~kjetism/radium/'
+license=(GPL2)
+groups=(ladspa-host pro-audio vst-host vst3-host)
+provides=($pkgname ladspa-host vst-host vst3-host)
+conflicts=($_pkgname)
+depends=(
+ alsa-lib
+ binutils
+ desktop-file-utils
+ fftw
+ glib2
+ glu
+ gmp
+ gsfonts
+ guile
+ hicolor-icon-theme
+ jack
+ ladspa
+ libatomic_ops
+ liblo
+ liblrdf
+ libmicrohttpd
+ libmpc
+ libmpc
+ libogg
+ libsamplerate
+ libsndfile
+ libvorbis
+ libxkbfile
+ mpfr
+ ncurses
+ openssl
+ openssl
+ python2
+ qt5-base
+ qt5-svg
+ qt5-webkit
+ qt5-x11extras
+ speex
+ swh-plugins
+ tk
+ ttf-bitstream-vera
+ ttf-croscore
+ ttf-lato
+ xcb-util-keysyms
+ xorg-util-macros
+)
+makedepends=(
+ boost
+ cmake
+ libxcursor
+ libxinerama
+ libxkbfile
+ libxrandr
+ llvm
+ qt5-tools
+ vst2sdk
+)
+optdepends=(
+ 'new-session-manager: for session management'
+ 'calf-ladspa: default chorus plugin used in new file templates'
+ 'ladspa-plugins: package group for plugins normally included in binary releases'
+ 'vst-plugins: more plugins'
+)
+options=(!strip)
+source=(
+ "git+https://github.com/kmatheussen/radium"
+ build_linux_common.patch
+)
+sha256sums=('SKIP'
+ '0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4')
+install=radium.install
+
+pkgver() {
+ cd radium
+
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd radium
+
+ git revert --no-commit f8c725e46791ce76fe71556b8dc1fac2d3bd35ff
+
+ # fix for binutils 2.40
+ patch -p0 -N -r - -i "$srcdir"/build_linux_common.patch
+
+ # This tweak edits the new file template and demo songs to be compatible with
+ # the multi chorus plugin from the 'calf-ladspa' package
+ for file in \
+ bin/{,sounds}/*.[Rr][Aa][Dd] \
+ audio/SoundPluginRegistry.cpp \
+ bin/scheme/instruments.scm \
+ ladspa_info/calf.7.cached_type_info; do
+ sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file";
+ done
+}
+
+build() {
+ cd radium
+
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 RADIUM_BUILD_LIBXCB=0 make packages
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 BUILDTYPE=RELEASE ./build_linux.sh
+}
+
+package() {
+ cd radium
+
+ # Install radium and its packages to /opt
+ RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir"/opt
+
+ # Create startup script according to bin/packages/README
+ echo '#!/usr/bin/env bash' > radium.sh
+ echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
+ /opt/radium/radium '"$@"' >> radium.sh
+ install -vDm 755 radium.sh "$pkgdir"/usr/bin/radium
+
+ # Icons, .desktop and mimetype files
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/{16x16,32x32,128x128,256x256}/apps \
+ "$pkgdir"/usr/share/applications \
+ "$pkgdir"/usr/share/mime/packages
+ ln -s /opt/radium/radium_16x16x8.png "$pkgdir"/usr/share/icons/hicolor/16x16/apps/radium.png
+ ln -s /opt/radium/radium_32x32x24.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/radium.png
+ ln -s /opt/radium/radium_128x128x32.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/radium.png
+ ln -s /opt/radium/radium_256x256x32.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/radium.png
+ ln -s /opt/radium/radium.desktop "$pkgdir"/usr/share/applications/radium.desktop
+ ln -s /opt/radium/radium-mimetype.xml "$pkgdir"/usr/share/mime/packages/radium.xml
+}
+
+warn_build_references() {
+ # Silence warning about build dir refs as Radium's author prefers packagers don't strip binaries.
+ # https://github.com/kmatheussen/radium/issues/1153#issuecomment-421543245
+ true
+}
diff --git a/build_linux_common.patch b/build_linux_common.patch
new file mode 100644
index 000000000000..cec22c044347
--- /dev/null
+++ b/build_linux_common.patch
@@ -0,0 +1,11 @@
+--- build_linux_common.sh.orig 2023-03-10 14:18:55.074248103 +0100
++++ build_linux_common.sh 2023-03-10 14:20:54.617578515 +0100
+@@ -216,7 +216,7 @@
+ if [[ $RADIUM_USE_CLANG == 1 ]] && [ -f "$CLANG_PREFIX/lib/libbfd.a" ]; then
+ export RADIUM_BFD_LDFLAGS="$CLANG_PREFIX/lib/libbfd.a"
+ else
+- export RADIUM_BFD_LDFLAGS="-Wl,-Bstatic -lbfd -Wl,-Bdynamic"
++ export RADIUM_BFD_LDFLAGS="-Wl,-Bstatic -lbfd -Wl,-Bdynamic -lzstd -lsframe"
+ fi
+ fi
+
diff --git a/radium.install b/radium.install
new file mode 100644
index 000000000000..f39d031dd2e9
--- /dev/null
+++ b/radium.install
@@ -0,0 +1,11 @@
+### should create a symlink to ladspa in /opt/radium
+### to get rid off the errormessage
+
+post_install() {
+ ln -sf /usr/lib/ladspa /opt/radium/ladspa
+}
+
+pre_remove() {
+ rm /opt/radium/ladspa
+}
+