summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryustin2023-04-02 18:57:55 +0200
committeryustin2023-04-02 18:57:55 +0200
commitcfeb92921c7928f5679bcf7190eb24ecfc207b6d (patch)
treeafd82c5b26f0b20c779cdb556b876cdf1871073d
parentadd1ba3378d51b17a6f121ce9c15cfd5d88fb3be (diff)
downloadaur-cfeb92921c7928f5679bcf7190eb24ecfc207b6d.tar.gz
7.1.88-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--xiinstruments.patch35
3 files changed, 8 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9245eced0597..fbdc6c45b3c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radium7
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 7.1.87
- pkgrel = 4
+ pkgver = 7.1.88
+ pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
install = radium.install
arch = x86_64
@@ -60,20 +60,17 @@ pkgbase = radium7
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
optdepends = vst-plugins: more plugins
options = !strip
- options = !lto
- source = radium7-7.1.87.tar.gz::https://github.com/kmatheussen/radium/archive/7.1.87.tar.gz
+ source = radium7-7.1.88.tar.gz::https://github.com/kmatheussen/radium/archive/7.1.88.tar.gz
source = add-vstsdk-location-var.patch
source = build_libpds.patch
source = radium.install
source = grep.patch
- source = xiinstruments.patch
source = build_linux_common.patch
- sha256sums = 897a6df56aedea417bbe146c85ee45f8b79bf749beac3a7c17568a42b5a9f9d9
+ sha256sums = 5b210984cb2a6cee6ba7e276b8a9ee1c157bfee136a47b79f63027873a7e84f0
sha256sums = ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e
sha256sums = 2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548
sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
sha256sums = 7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3
- sha256sums = c1937b1d7846c469f477e060a71b6785e7cc24cc5ba6f58374e219fa6504ee5a
sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
pkgname = radium7
diff --git a/PKGBUILD b/PKGBUILD
index 3173d1669d7b..49fb29eeedb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: yustin <#archlinux-proaudio@libera.chat>
pkgname=radium7
-pkgver=7.1.87
-pkgrel=4
+pkgver=7.1.88
+pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
url=https://users.notam02.no/~kjetism/radium
@@ -69,31 +69,25 @@ optdepends=(
'ladspa-plugins: package group for plugins normally included in binary releases'
'vst-plugins: more plugins'
)
-options=(!strip
- !lto )
+options=( !strip )
source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
add-vstsdk-location-var.patch
build_libpds.patch
radium.install
grep.patch
- xiinstruments.patch
build_linux_common.patch
)
-sha256sums=('897a6df56aedea417bbe146c85ee45f8b79bf749beac3a7c17568a42b5a9f9d9'
+sha256sums=('5b210984cb2a6cee6ba7e276b8a9ee1c157bfee136a47b79f63027873a7e84f0'
'ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e'
'2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548'
'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
'7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3'
- 'c1937b1d7846c469f477e060a71b6785e7cc24cc5ba6f58374e219fa6504ee5a'
'0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4'
)
install=radium.install
prepare() {
cd radium-$pkgver
- #makes all xiinstruments available in local browser
- patch -p1 < "$srcdir/xiinstruments.patch"
-
#sed "/grep [^\-]*\\\ /s/grep \([^\]*\)\\\ \([^ ]*\)/grep \"\1 \2\"/p" -i check_dependencies.sh
patch -p0 < "$srcdir/grep.patch"
diff --git a/xiinstruments.patch b/xiinstruments.patch
deleted file mode 100644
index d1f049ab73f4..000000000000
--- a/xiinstruments.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/Qt/Qt_sample_requester_widget_callbacks.h b/Qt/Qt_sample_requester_widget_callbacks.h
-index 9ee2158be..67d58e40d 100644
---- a/Qt/Qt_sample_requester_widget_callbacks.h
-+++ b/Qt/Qt_sample_requester_widget_callbacks.h
-@@ -126,20 +126,22 @@ static QString get_sample_filename_display_string(QFileInfo file_info, int width
- //printf("Trying to open %s\n",file_info.absoluteFilePath().toUtf8().constData());
- SNDFILE *sndfile = radium_sf_open(full_filename, SFM_READ, &sf_info);
-
-- if(sndfile==NULL)
-- return QString();
--
-- num_channels = sf_info.channels;
-+ if(sndfile==NULL){
-+ num_channels = -1;
-+ }else{
-+ num_channels = sf_info.channels;
-
-- sf_close(sndfile);
-+ sf_close(sndfile);
-+ }
- }
-
- int64_t num_bytes = file_info.size();
-
- //const QFontMetrics fn = QFontMetrics(font);
-- QString ret =
-- file_info.fileName().leftJustified(k_filename_len-2,'.') +
-- ".." + QString::number(num_channels)+"ch,";
-+ QString ret = file_info.fileName().leftJustified(k_filename_len-2,'.');
-+
-+ if (num_channels >= 0)
-+ ret += ".." + QString::number(num_channels)+"ch,";
-
- {
- QString size_string;