summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlieven moors2016-07-25 13:19:20 +0200
committerlieven moors2016-07-25 13:19:20 +0200
commit5d409729a2903604cfc25df6239bf6cec8805551 (patch)
tree6c44e024be8182ab68e24075e070093dbb80476a
downloadaur-5d409729a2903604cfc25df6239bf6cec8805551.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--Makefile.patch40
-rw-r--r--PKGBUILD38
-rw-r--r--radium_compressor.desktop8
-rw-r--r--radium_compressor.pngbin0 -> 1355 bytes
5 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..782a2d65f2d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Jul 25 11:19:20 UTC 2016
+pkgbase = radium_compressor
+ pkgdesc = A standalone jack audio compressor
+ pkgver = 0.5.1
+ pkgrel = 5
+ url = http://users.notam02.no/~kjetism/radium/compressor_plugin.php
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = faust
+ depends = jack
+ depends = qt4
+ source = http://archive.notam02.no/arkiv/src/radium_compressor-0.5.1.tar.gz
+ source = radium_compressor.desktop
+ source = radium_compressor.png
+ source = Makefile.patch
+ md5sums = d6e24bb1ef4f279adda07ff6e10f3601
+ md5sums = 19b176fb5434ebd1ef2e4fcd21081e6b
+ md5sums = c535752663bd92f3467e9aef7a5316fe
+ md5sums = 48e3e1ee69f0234db1a4bad7af973283
+
+pkgname = radium_compressor
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..018551b5b9d1
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,40 @@
+--- Makefile 2013-01-26 12:55:27.000000000 +0100
++++ Makefile.new 2013-04-02 05:21:32.793326231 +0200
+@@ -1,7 +1,9 @@
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ bindir ?= $(PREFIX)/bin
+ libdir ?= $(PREFIX)/lib
+
++UIC = uic-qt4
++MOC = moc-qt4
+
+ # These two commands are used by me, since most of the source files are stored in the Radium tree.
+ # You would normally just run "make" to compile the program.
+@@ -9,8 +11,7 @@
+ # make copy_files && make all && ./radium_compressor
+ # make copy_files && rm -f benchmark && make benchmark && ./benchmark && ./benchmark && ./benchmark
+
+-
+-CPP = g++ -DDEBUG -O3 -Wall -msse -mfpmath=sse -DUSE_QT_REQTYPE -DUSE_QT4 -g -I. -ffast-math -IQt
++CPP = g++ $(CXXFLAGS) -DDEBUG -O3 -Wall -msse -mfpmath=sse -DUSE_QT_REQTYPE -DUSE_QT4 -I. -ffast-math -IQt
+
+ #FAUST = /home/kjetil/faudiostream/compiler/faust -vec
+ FAUST = faust -vec
+@@ -19,14 +20,14 @@
+ RADIUM_PATH = /home/kjetil/radium-qt4
+
+ all: audio/system_compressor.cpp
+- cd Qt && ./create_source_from_ui.sh `../find_moc_and_uic_paths.sh uic` `../find_moc_and_uic_paths.sh moc` compressor_widget
++ cd Qt && ./create_source_from_ui.sh $(UIC) $(MOC) compressor_widget
+ $(CPP) Qt/Qt_SliderPainter.cpp `pkg-config --cflags Qt3Support` -c
+ $(CPP) main.cpp Qt_SliderPainter.o -Iaudio/faudiostream/architecture/ `pkg-config --libs --cflags Qt3Support` -ljack -o radium_compressor
+
+
+ install:
+ install -d $(DESTDIR)$(bindir)
+- cp radium_compressor $(DESTDIR)$(bindir)/
++ install -m755 radium_compressor $(DESTDIR)$(bindir)/
+
+
+ uninstall:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..455b5e4ac139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lieven Moors lievenmoors<aT>gmail<d0t>com
+# Contributor: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
+
+pkgname=radium_compressor
+pkgver=0.5.1
+pkgrel=5
+pkgdesc="A standalone jack audio compressor"
+arch=(i686 x86_64)
+url="http://users.notam02.no/~kjetism/radium/compressor_plugin.php"
+license=('GPL2')
+depends=(jack qt4)
+makedepends=(faust)
+source=("http://archive.notam02.no/arkiv/src/$pkgname-$pkgver.tar.gz"
+ "radium_compressor.desktop"
+ "radium_compressor.png"
+ "Makefile.patch")
+
+md5sums=('d6e24bb1ef4f279adda07ff6e10f3601'
+ '19b176fb5434ebd1ef2e4fcd21081e6b'
+ 'c535752663bd92f3467e9aef7a5316fe'
+ '48e3e1ee69f0234db1a4bad7af973283')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 -i ../Makefile.patch
+ make
+# make CXXFLAGS="-march=native"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 ../$pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/radium_compressor.desktop b/radium_compressor.desktop
new file mode 100644
index 000000000000..f4e90eeb76ef
--- /dev/null
+++ b/radium_compressor.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Radium_compressor
+Comment=A standalone jack audio compressor
+Exec=radium_compressor
+Icon=radium_compressor
+Categories=AudioVideo;Audio;
+Terminal=false
+Type=Application
diff --git a/radium_compressor.png b/radium_compressor.png
new file mode 100644
index 000000000000..9cd66074c63f
--- /dev/null
+++ b/radium_compressor.png
Binary files differ