summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-01-29 07:53:51 +0000
committerMilk Brewster2020-01-29 07:53:51 +0000
commitad1bef9a7ef27cedcfd8bc23107a6d0af1726804 (patch)
tree5211470f8985b0ffe26030ebd11c6d4015371a4d
downloadaur-ad1bef9a7ef27cedcfd8bc23107a6d0af1726804.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--radium_compressor.desktop8
-rw-r--r--radium_compressor.pngbin0 -> 1355 bytes
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25a125712574
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = radium_compressor-git
+ pkgdesc = A standalone JACK audio compressor
+ pkgver = 0.5.1.r10.gc19c3e3
+ pkgrel = 1
+ url = http://users.notam02.no/~kjetism/radium/compressor_plugin.php
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = faust
+ depends = jack
+ depends = qt5-base
+ provides = radium_compressor
+ conflicts = radium_compressor
+ source = git+https://github.com/kmatheussen/radium_compressor
+ source = radium_compressor.desktop
+ source = radium_compressor.png
+ md5sums = SKIP
+ md5sums = 19b176fb5434ebd1ef2e4fcd21081e6b
+ md5sums = c535752663bd92f3467e9aef7a5316fe
+
+pkgname = radium_compressor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e10de705abc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: milkii on Freenode
+# Maintainer: Lieven Moors lievenmoors<aT>gmail<d0t>com
+# Contributor: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
+
+
+_pkgname=radium_compressor
+pkgname=${_pkgname}-git
+pkgver=0.5.1.r10.gc19c3e3
+pkgrel=1
+pkgdesc="A standalone JACK audio compressor"
+arch=(i686 x86_64)
+url="http://users.notam02.no/~kjetism/radium/compressor_plugin.php"
+license=('GPL2')
+conflicts=('radium_compressor')
+provides=('radium_compressor')
+depends=(jack qt5-base)
+makedepends=(faust)
+source=("git+https://github.com/kmatheussen/radium_compressor"
+ "radium_compressor.desktop"
+ "radium_compressor.png")
+
+md5sums=('SKIP'
+ '19b176fb5434ebd1ef2e4fcd21081e6b'
+ 'c535752663bd92f3467e9aef7a5316fe')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ # patch -p0 -i ../Makefile.patch
+ make
+# make CXXFLAGS="-march=native"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 ../$_pkgname.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
+ install -Dm644 ../$_pkgname.png "$pkgdir"/usr/share/pixmaps/$_pkgname.png
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/radium_compressor.desktop b/radium_compressor.desktop
new file mode 100644
index 000000000000..f4e90eeb76ef
--- /dev/null
+++ b/radium_compressor.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Radium_compressor
+Comment=A standalone jack audio compressor
+Exec=radium_compressor
+Icon=radium_compressor
+Categories=AudioVideo;Audio;
+Terminal=false
+Type=Application
diff --git a/radium_compressor.png b/radium_compressor.png
new file mode 100644
index 000000000000..9cd66074c63f
--- /dev/null
+++ b/radium_compressor.png
Binary files differ