summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornetworkjanitor2020-05-04 23:59:59 +0200
committernetworkjanitor2020-05-04 23:59:59 +0200
commite3e8ef5d22758dbefe3f0441574a58d3163fa698 (patch)
tree24923b1c8c647e1002faf9af62dee231992ffaef
parentf82edeb9fb0a4e1b07c0cc404625c37ffab05399 (diff)
downloadaur-e3e8ef5d22758dbefe3f0441574a58d3163fa698.tar.gz
added --locked, removed git submodules since evtclib is now published on crate.io
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77d84c946b39..52b89ceb0420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = raidgrep-git
- pkgdesc = Guild Wars 2/arcdps evtc log searching tool. Build from master branch using the rust nightly toolchain.
- pkgver = 1.0.2.r8.g0d1898a
- pkgrel = 2
+ pkgdesc = Guild Wars 2/arcdps evtc log searching tool. Built[sic] from master branch using the rust nightly toolchain.
+ pkgver = 1.1.0.r0.g684024e
+ pkgrel = 1
url = https://gitlab.com/dunj3/raidgrep
arch = x86_64
license = GPL
makedepends = cargo
makedepends = rustup
- makedepends = git
makedepends = asciidoc
depends = gcc-libs
provides = raidgrep
diff --git a/PKGBUILD b/PKGBUILD
index 64e506396ab0..1d6d139b42e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: networkjanitor <networkjanitor@xyooz.net>
pkgname=raidgrep-git
_pkgname=raidgrep
-pkgver=1.0.2.r8.g0d1898a
-pkgrel=2
-pkgdesc="Guild Wars 2/arcdps evtc log searching tool. Build from master branch using the rust nightly toolchain."
+pkgver=1.1.0.r0.g684024e
+pkgrel=1
+pkgdesc="Guild Wars 2/arcdps evtc log searching tool. Built[sic] from master branch using the rust nightly toolchain."
arch=("x86_64")
url="https://gitlab.com/dunj3/raidgrep"
license=("GPL")
provides=("${_pkgname}")
conflicts=("${_pkgname}-bin" "${_pkgname}")
-makedepends=('cargo' 'rustup' 'git' 'asciidoc')
+makedepends=('cargo' 'rustup' 'asciidoc')
depends=("gcc-libs")
source=(
"${_pkgname}::git+https://gitlab.com/dunj3/raidgrep.git#branch=master"
@@ -23,19 +23,18 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- git submodule init && git submodule update
rustup install nightly
}
build() {
cd "${_pkgname}"
- cargo +nightly build --release
- a2x -vv --no-xmllint -f manpage "${_pkgname}.1.asciidoc"
+ cargo +nightly build --release --locked
+ a2x -f manpage "${_pkgname}.1.asciidoc"
}
check() {
cd "${_pkgname}"
- cargo +nightly test --release
+ cargo +nightly test --release --locked
}
package() {