summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariszo2017-11-10 23:09:18 +0100
committerMariszo2017-11-10 23:09:18 +0100
commit15a441d8f490296268af9d0e8b2f0b2c8bd24e7e (patch)
tree2340e5b5e761304cf9296be46da5ad934c953809
downloadaur-15a441d8f490296268af9d0e8b2f0b2c8bd24e7e.tar.gz
initial commit - v1.0.4.47.bedd974597
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6762dcdca81b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = railcar-git
+ pkgdesc = Rust implementation of the Open Containers Initiative oci-runtime
+ pkgver = 1.0.4.47.bedd974597
+ pkgrel = 1
+ url = https://github.com/oracle/railcar
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = rustup
+ depends = gcc-libs
+ depends = libseccomp
+ provides = railcar
+ conflicts = railcar
+ source = git+https://github.com/oracle/railcar.git
+ sha512sums = SKIP
+
+pkgname = railcar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd6e908eb3e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: Mariszo <mariszo@itfinger.com>
+#Contributor: Mariszo <mariszo@itfinger.com>
+
+pkgname=railcar-git
+pkgver=1.0.4.47.bedd974597
+pkgrel=1
+pkgdesc="Rust implementation of the Open Containers Initiative oci-runtime"
+url="https://github.com/oracle/railcar"
+depends=('gcc-libs' 'libseccomp')
+makedepends=('git' 'rustup')
+conflicts=('railcar')
+arch=('x86_64')
+provides=('railcar')
+license=("APACHE")
+source=('git+https://github.com/oracle/railcar.git')
+sha512sums=('SKIP')
+
+prepare() {
+ rustup toolchain install stable-$CARCH-unknown-linux-gnu
+ rustup default stable-$CARCH-unknown-linux-gnu
+ rustup target install $CARCH-unknown-linux-musl
+
+ cargo install cargo-when --force
+}
+
+build() {
+ cd railcar
+ ./build.sh
+}
+
+package() {
+ install -D -m 0755 railcar/railcar "$pkgdir/usr/bin/railcar"
+}
+