summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian2023-05-17 07:05:45 +0200
committerJulian2023-05-17 07:05:45 +0200
commit0fc9b4030a5f59871c709dfc6586b31cf111af05 (patch)
tree50489917b5db2e40d4514956680750b10c93beef
downloadaur-0fc9b4030a5f59871c709dfc6586b31cf111af05.tar.gz
Add DieBahn
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e228e96322da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = diebahn
+ pkgdesc = GTK4 frontend for the travel information of the german railway
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://gitlab.com/Schmiddiii/diebahn
+ arch = any
+ license = AGPL3
+ makedepends = cargo
+ makedepends = meson
+ depends = libadwaita
+ depends = libsecret
+ depends = protobuf
+ options = !lto
+ source = https://gitlab.com/Schmiddiii/diebahn/-/archive/1.3.0/diebahn-1.3.0.tar.gz
+ sha256sums = 97739b7c7458471e8ac61d9b534b617e47243df9102dc7064e61a8cf6a21e6a7
+
+pkgname = diebahn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec8f9e1d2b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Julian <juliannfairfax@protonmail.com>
+
+pkgname=diebahn
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="GTK4 frontend for the travel information of the german railway"
+url="https://gitlab.com/Schmiddiii/$pkgname"
+arch=("any")
+license=("AGPL3")
+makedepends=("cargo" "meson")
+depends=("libadwaita" "libsecret" "protobuf")
+source=("https://gitlab.com/Schmiddiii/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=("97739b7c7458471e8ac61d9b534b617e47243df9102dc7064e61a8cf6a21e6a7")
+options=(!lto)
+
+build() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ arch-meson . _build
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ DESTDIR="${pkgdir}" ninja -C _build install
+}