summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2021-04-06 00:09:53 +0200
committertrya2021-04-06 00:10:20 +0200
commit766a02e31aa70fe42fb3df7c5a4dc04cfcfa8f3c (patch)
tree884ca459ed64daf09ba42a04e35517d233afc68d
parentfec50a12aebe95dd2e4f773d4229a9a3c5cf3790 (diff)
downloadaur-raine.tar.gz
Update to current source base without ASM code
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
2 files changed, 22 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb3e2b6060c1..79bf8adde638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,30 @@
pkgbase = raine
- pkgdesc = A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo
- pkgver = 0.64.16
+ pkgdesc = A multiple arcade emulator focused on 680x0/z80 machines like NeoCD and Neo Geo, C version
+ pkgver = 0.91.15b
pkgrel = 1
url = http://raine.1emulation.com/
arch = i686
arch = x86_64
license = custom
- makedepends = nasm
makedepends = mesa
- optdepends = raine-artwork: additional background graphics for some games
optdepends = raine-emudx: improved graphic and sound files for some classic games
- optdepends = raine-blend: transparency information for some games
optdepends = arcade-history-dat: database with various information about the loaded rom
optdepends = arcade-command-dat: database with button combinations for special moves in (mostly fighting) games
replaces = neoraine
+ replaces = raine64
options = emptydirs
- source = raine-0.64.16.tar.gz::https://github.com/zelurker/raine/archive/0.64.16.tar.gz
- source = http://raine.1emulation.com//archive/debian/dists/unstable/main/binary-i386/raine_0.64.13_i386.deb
- sha256sums = f0c9a1807610a9b035ada20362321cabbb08079d205b639d14b2071f275f0358
- sha256sums = 71414fc61c1d26eeccfab4f7319ba9efce19b8276151d3a119fd86c3db0a172b
+ source = raine-0.91.15b.tar.gz::https://github.com/zelurker/raine/archive/0.91.15b.tar.gz
+ sha256sums = 4202004ad6dbd13995bf8e879c961ab4932990393443b2beccf87e911ddfe3e9
depends_i686 = sdl_ttf
depends_i686 = sdl_image
depends_i686 = sdl_sound
depends_i686 = muparser
depends_i686 = glu
- depends_x86_64 = lib32-sdl_ttf
- depends_x86_64 = lib32-sdl_image
- depends_x86_64 = lib32-sdl_sound
- depends_x86_64 = lib32-muparser
- depends_x86_64 = lib32-glu
- makedepends_x86_64 = gcc-multilib
+ depends_x86_64 = sdl_ttf
+ depends_x86_64 = sdl_image
+ depends_x86_64 = sdl_sound
+ depends_x86_64 = muparser
+ depends_x86_64 = glu
pkgname = raine
diff --git a/PKGBUILD b/PKGBUILD
index f34681194e01..ac298e95a528 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,45 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: trya <tryagainprod@gmail.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=raine
-pkgver=0.64.16
+pkgver=0.91.15b
pkgrel=1
-pkgdesc="A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo"
+pkgdesc="A multiple arcade emulator focused on 680x0/z80 machines like NeoCD and Neo Geo, C version"
url="http://raine.1emulation.com/"
license=('custom')
arch=('i686' 'x86_64')
-replaces=('neoraine')
+replaces=('neoraine' 'raine64')
depends_i686=('sdl_ttf' 'sdl_image' 'sdl_sound' 'muparser' 'glu')
-depends_x86_64=('lib32-sdl_ttf' 'lib32-sdl_image' 'lib32-sdl_sound' 'lib32-muparser' 'lib32-glu')
-makedepends=('nasm' 'mesa')
-makedepends_x86_64=('gcc-multilib')
-optdepends=('raine-artwork: additional background graphics for some games'
- 'raine-emudx: improved graphic and sound files for some classic games'
- 'raine-blend: transparency information for some games'
+depends_x86_64=('sdl_ttf' 'sdl_image' 'sdl_sound' 'muparser' 'glu')
+makedepends=('mesa')
+optdepends=('raine-emudx: improved graphic and sound files for some classic games'
'arcade-history-dat: database with various information about the loaded rom'
'arcade-command-dat: database with button combinations for special moves in (mostly fighting) games')
-source=(raine-$pkgver.tar.gz::"https://github.com/zelurker/raine/archive/$pkgver.tar.gz"
- "$url/archive/debian/dists/unstable/main/binary-i386/raine_0.64.13_i386.deb")
-sha256sums=('f0c9a1807610a9b035ada20362321cabbb08079d205b639d14b2071f275f0358'
- '71414fc61c1d26eeccfab4f7319ba9efce19b8276151d3a119fd86c3db0a172b')
+source=(raine-$pkgver.tar.gz::"https://github.com/zelurker/raine/archive/$pkgver.tar.gz")
+sha256sums=('4202004ad6dbd13995bf8e879c961ab4932990393443b2beccf87e911ddfe3e9')
options=('emptydirs')
prepare() {
cd "$srcdir"
mkdir -p raine-bin
- bsdtar xf data.tar.xz -C raine-bin
cd raine-$pkgver
- # copy bitmaps and fonts from raine's old deb package
- cp -rup "$srcdir"/raine-bin/usr/share/games/raine/bitmaps .
- cp -rup "$srcdir"/raine-bin/usr/share/games/raine/fonts .
# adapt folder structure to arch standards
sed 's|$(prefix)/games|\$(prefix)/bin|;s|$(prefix)/share/games|\$(prefix)/share|' -i makefile
sed 's|share/games/raine|share/raine|' -i source/sdl/dialogs/about.cpp source/raine.c
-
- # -O3 optimizations cause segfaults, use -O2 instead
- sed 's|-O3|-O2|g' -i makefile
-
- # fix building with dynamic library of SDL_sound
- # https://github.com/zelurker/raine/commit/705db312376464d15c867142603e4ed4ac9dbbba
- sed 's|using system SDL_sound.*|"&"|' -i makefile
-
- # 'detect-cpu' script does not recognize most recent cpus, use generic optimizing
- echo "_MARCH=-march=${CARCH/x86_64/x86-64} -mtune=generic" > cpuinfo
- echo "CPU=generic" >> cpuinfo
}
build() {
- make -C "$srcdir"/raine-$pkgver #VERBOSE=1
+ make NO_ASM=1 -C "$srcdir"/raine-$pkgver #VERBOSE=1
}
package() {
- cd "$srcdir"/raine-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/raine-$pkgver"
+ make NO_ASM=1 DESTDIR="$pkgdir" install
# doc + license
install -d "$pkgdir"/usr/share/{doc,licenses}/raine
install -m644 docs/* changes/* "$pkgdir"/usr/share/doc/raine
head -n5 source/raine.c > "$pkgdir"/usr/share/licenses/raine/LICENSE
- rm "$pkgdir"/usr/share/{applications,pixmaps}/neoraine.*
}