summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-04-01 20:26:08 +0200
committerCarsten Teibes2015-04-01 20:26:08 +0200
commit29faaf58a4c7210a664c3e472fd66440c561c547 (patch)
tree8aafa0a132d8653266a116ec382af07a1f671ada
parent332372689845b99a282bf67c187948f1726ab7fd (diff)
downloadaur-29faaf58a4c7210a664c3e472fd66440c561c547.tar.gz
[upd] 0.64.02→0.64.4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD18
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fcb814ad368..3b0be8549d79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
pkgbase = raine
pkgdesc = A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo
- pkgver = 0.64.02
+ pkgver = 0.64.4
pkgrel = 1
url = http://rainemu.swishparty.co.uk
arch = i686
arch = x86_64
license = custom
makedepends = nasm
- depends = sdl_ttf
- depends = sdl_image
- depends = sdl_sound
- depends = muparser
- depends = glu
- depends = mesa
+ makedepends = mesa
optdepends = raine-artwork: additional background graphics for some games
optdepends = raine-emudx: improved graphic and sound files for some classic games
optdepends = raine-blend: transparency information for some games
@@ -22,10 +17,21 @@ pkgbase = raine
conflicts = neoraine
replaces = neoraine
options = emptydirs
- source = raine-0.64.02.tar.gz::http://rainemu.swishparty.co.uk/cgi-bin/gitweb.cgi?p=raine;a=snapshot;h=2629ef6;sf=tgz
- source = http://rainemu.swishparty.co.uk/html/archive/debian/dists/unstable/main/binary-i386/raine_0.64.02_i386.deb
- sha256sums = a49fb609741cc55cf3285c04918c10f0d6f282e09a67fd9295130a585fa15a84
- sha256sums = 085bf8b8d0656c350baec202cdea3aa8362f620e6a0926109b60a42d782b6b57
+ source = raine-0.64.4.tar.gz::http://rainemu.swishparty.co.uk/cgi-bin/gitweb.cgi?p=raine;a=snapshot;h=38ad235;sf=tgz
+ source = http://rainemu.swishparty.co.uk/html/archive/debian/dists/unstable/main/binary-i386/raine_0.64.4_i386.deb
+ sha256sums = 797a444d685a6d268a0814f2c570120a0e2f1765fa98ae0ce14bae90e37f2a06
+ sha256sums = f799bc25f095d9e0685649c280ed28c72ec0d3bb93285c3ed21e7f94e157b7ec
+ depends_i686 = sdl_ttf
+ depends_i686 = sdl_image
+ depends_i686 = sdl_sound
+ depends_i686 = muparser
+ depends_i686 = glu
+ depends_x86_64 = lib32-sdl_ttf
+ depends_x86_64 = lib32-sdl_image
+ depends_x86_64 = lib32-sdl_sound
+ depends_x86_64 = lib32-muparser
+ depends_x86_64 = lib32-glu
+ makedepends_x86_64 = gcc-multilib
pkgname = raine
diff --git a/PKGBUILD b/PKGBUILD
index a97cf8710980..ad2bfd82d01c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=raine
-pkgver=0.64.02
-_gitver=2629ef6
+pkgver=0.64.4
+_gitver=38ad235
pkgrel=1
pkgdesc="A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo"
url="http://rainemu.swishparty.co.uk"
@@ -13,12 +13,10 @@ arch=('i686' 'x86_64')
provides=('neoraine')
conflicts=('neoraine')
replaces=('neoraine')
-depends=('sdl_ttf' 'sdl_image' 'sdl_sound' 'muparser' 'glu' 'mesa')
-makedepends=('nasm')
-if [ "$CARCH" == "x86_64" ]; then
- depends=('lib32-sdl_ttf' 'lib32-sdl_image' 'lib32-sdl_sound' 'lib32-muparser' 'lib32-glu' 'lib32-mesa')
- makedepends+=('gcc-multilib')
-fi
+depends_i686=('sdl_ttf' 'sdl_image' 'sdl_sound' 'muparser' 'glu')
+depends_x86_64=('lib32-sdl_ttf' 'lib32-sdl_image' 'lib32-sdl_sound' 'lib32-muparser' 'lib32-glu')
+makedepends=('nasm' 'mesa')
+makedepends_x86_64=('gcc-multilib')
optdepends=('raine-artwork: additional background graphics for some games'
'raine-emudx: improved graphic and sound files for some classic games'
'raine-blend: transparency information for some games'
@@ -26,8 +24,8 @@ optdepends=('raine-artwork: additional background graphics for some games'
'arcade-command-dat: database with button combinations for special moves in (mostly fighting) games')
source=(raine-$pkgver.tar.gz::"$url/cgi-bin/gitweb.cgi?p=raine;a=snapshot;h=$_gitver;sf=tgz"
"$url/html/archive/debian/dists/unstable/main/binary-i386/raine_${pkgver}_i386.deb")
-sha256sums=('a49fb609741cc55cf3285c04918c10f0d6f282e09a67fd9295130a585fa15a84'
- '085bf8b8d0656c350baec202cdea3aa8362f620e6a0926109b60a42d782b6b57')
+sha256sums=('797a444d685a6d268a0814f2c570120a0e2f1765fa98ae0ce14bae90e37f2a06'
+ 'f799bc25f095d9e0685649c280ed28c72ec0d3bb93285c3ed21e7f94e157b7ec')
options=('emptydirs')
prepare() {