summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁdám Maróti2016-03-19 18:49:55 +0100
committerÁdám Maróti2016-03-19 20:38:30 +0100
commita905202416ed1bc721dc88ab256c376bd1a12f32 (patch)
treee2b80b908ecb12655b48ccaa81d8a7f53b1fd900
downloadaur-a905202416ed1bc721dc88ab256c376bd1a12f32.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14194967a0bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rainicorn
+ pkgdesc = Rainicorn is a tool intended for use by Rust IDEs.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/RustDT/Rainicorn
+ arch = x86
+ arch = x86_64
+ license = APACHE
+ makedepends = cargo
+ depends = gcc-libs
+ provides = rainicorn
+ conflicts = rainicorn-git
+ source = rainicorn::git+https://github.com/RustDT/Rainicorn.git
+ sha1sums = SKIP
+
+pkgname = rainicorn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d1ecaf25152
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+_pkgname=rainicorn
+pkgname=$_pkgname
+pkgver=1.0.0
+arch=('x86' 'x86_64')
+pkgrel=1
+pkgdesc="Rainicorn is a tool intended for use by Rust IDEs."
+url="https://github.com/RustDT/Rainicorn"
+provides=("$_pkgname")
+conflicts=("$_pkgname-git")
+source=("$_pkgname::git+${url}.git")
+sha1sums=('SKIP')
+depends=('gcc-libs')
+makedepends=('cargo')
+license=('APACHE')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git checkout version_1.x
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cargo build --release
+}
+
+#check() {
+# cd "$srcdir/$_pkgname"
+# cargo test --release
+#}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ cargo install --root "$pkgdir/"
+ mkdir -p "$pkgdir/usr"
+ mv "$pkgdir/bin" "$pkgdir/usr/bin"
+}