summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio2017-10-28 12:56:53 +0200
committerFabio2017-10-28 12:56:53 +0200
commit99c27febafc4bfcbecf4467eee1eb8810329a0ed (patch)
treef1e02104be064f6ae3f4477226106b90beb7cd2f
downloadaur-99c27febafc4bfcbecf4467eee1eb8810329a0ed.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bb05acc2e1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = raiseorlaunch
+ pkgdesc = Run-or-raise-application-launcher for i3 window manager.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/open-dynaMIX/raiseorlaunch
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-i3-py
+ source = https://github.com/open-dynaMIX/raiseorlaunch/archive/v0.1.1.tar.gz
+ sha256sums = c2984485721479404f397d4496792a2f6b5894a291cac6768049232aedf9de26
+
+pkgname = raiseorlaunch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59d8a41c939a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Fabio Rämi <fabio[at]dynamix-tontechnik[dot]ch>
+
+pkgname=raiseorlaunch
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Run-or-raise-application-launcher for i3 window manager."
+arch=(any)
+url="https://github.com/open-dynaMIX/raiseorlaunch"
+license=('MIT')
+depends=('python' 'python-i3-py')
+makedepends=('python-setuptools')
+source=("https://github.com/open-dynaMIX/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('c2984485721479404f397d4496792a2f6b5894a291cac6768049232aedf9de26')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}