summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-13 18:52:24 +0800
committerzxp198210052023-12-13 18:52:24 +0800
commite1742f533f0696fa40403955ea1a194520aac27e (patch)
tree62a436f1e45971d1390626ebe70f05748f527fb0
parent48ffeab2c7050370dd950d4a666bb22d2022f375 (diff)
downloadaur-e1742f533f0696fa40403955ea1a194520aac27e.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--raj-browser.sh16
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce3d9ab16f1..b6ca90a1e2d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = raj-browser-bin
pkgdesc = A UI and privacy focussed browser for the web from the web.
pkgver = 2.0.5
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Rajaniraiyn/raj-browser
arch = x86_64
license = custom
- depends = bash
depends = electron22
conflicts = raj-browser
source = raj-browser-2.0.5.deb::https://github.com/Rajaniraiyn/raj-browser/releases/download/v2.0.5/raj-browser_2.0.5_amd64.deb
source = raj-browser.sh
sha256sums = b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79
- sha256sums = ea63cc87484f5ca49318425a9ee2c5c9ac3920d5de6613634ad37a8c397cdf70
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = raj-browser-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1c8aa7f9af11..615ad04fba23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=raj-browser-bin
pkgver=2.0.5
-pkgrel=3
+_electronversion=22
+pkgrel=4
pkgdesc="A UI and privacy focussed browser for the web from the web."
arch=('x86_64')
license=('custom')
conflicts=("${pkgname%-bin}")
url="https://github.com/Rajaniraiyn/raj-browser"
depends=(
- 'bash'
- 'electron22'
+ "electron${_electronversion}"
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh"
)
sha256sums=('b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79'
- 'ea63cc87484f5ca49318425a9ee2c5c9ac3920d5de6613634ad37a8c397cdf70')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${pkgname%-bin}/${pkgname%-bin} %U|${pkgname%-bin}|g;s|Utility|Network;Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/raj-browser.sh b/raj-browser.sh
index 23c7b6dcb558..2ec4412e5c4f 100644
--- a/raj-browser.sh
+++ b/raj-browser.sh
@@ -1,10 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron22
-APPDIR="/usr/lib/raj-browser"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file