summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2015-12-28 00:22:17 +0100
committerspider-mario2015-12-28 00:22:17 +0100
commit9bac6faea77c87501c36b40386fe913135a663b1 (patch)
tree5c0b902999c52a10d6a643a88a3b539e9e7187e3
parent675d40fb52f0e5531cf16048330a20b2cad5675c (diff)
downloadaur-9bac6faea77c87501c36b40386fe913135a663b1.tar.gz
2015.12
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--install.patch39
3 files changed, 58 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e0a97c9a603..c74916ef7cbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 23:22:00 UTC 2015
pkgbase = rakudo
pkgdesc = Perl6 compiler for MoarVM
- pkgver = 2015.11
+ pkgver = 2015.12
pkgrel = 1
url = http://rakudo.org/
arch = i686
arch = x86_64
license = PerlArtistic
makedepends = perl>=5.8
- depends = nqp>=2015.11
+ depends = nqp>=2015.12
provides = rakudo-moarvm
conflicts = rakudo-moarvm
replaces = rakudo-moarvm
options = !makeflags
- source = http://rakudo.org/downloads/rakudo/rakudo-2015.11.tar.gz
- sha512sums = e4d662709cf47b2b98398c5781973d1abd008f6f13b170fdba418bf36ff552e6c33caee26e2833539828c06ab7562f02cf5e54789f898e2e2d1d31db98d2e95e
+ source = http://rakudo.org/downloads/rakudo/rakudo-2015.12.tar.gz
+ source = install.patch
+ sha512sums = 48e4c98bbff67a52f68a835cc87a19a0b17f2d67790f8162ffd9f167f080d09180d375b5ea9a8577d1de5036c78e604473a2140107d448aff3630c138fd16114
+ sha512sums = f011a6805c9251a6ac70cd5497b62b2663f3e35f660c4daa1871ce9adcf3c6ba870979ecfc62c4fea49857cc7eddaa1c515f470d0f8c43d0fc26daa76ab02556
pkgname = rakudo
diff --git a/PKGBUILD b/PKGBUILD
index 0c0cda902e58..9251b5cc228e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Marcin Karpezo <sirmacik at gmail dot com>
# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
pkgname=rakudo
-pkgver=2015.11
+pkgver=2015.12
pkgrel=1
pkgdesc="Perl6 compiler for MoarVM"
arch=('i686' 'x86_64')
@@ -14,8 +14,14 @@ provides=('rakudo-moarvm')
replaces=('rakudo-moarvm')
conflicts=('rakudo-moarvm')
options=('!makeflags')
-source=(http://rakudo.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz)
-sha512sums=('e4d662709cf47b2b98398c5781973d1abd008f6f13b170fdba418bf36ff552e6c33caee26e2833539828c06ab7562f02cf5e54789f898e2e2d1d31db98d2e95e')
+source=(http://rakudo.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz install.patch)
+sha512sums=('48e4c98bbff67a52f68a835cc87a19a0b17f2d67790f8162ffd9f167f080d09180d375b5ea9a8577d1de5036c78e604473a2140107d448aff3630c138fd16114'
+ 'f011a6805c9251a6ac70cd5497b62b2663f3e35f660c4daa1871ce9adcf3c6ba870979ecfc62c4fea49857cc7eddaa1c515f470d0f8c43d0fc26daa76ab02556')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < ../install.patch
+}
build() {
cd "$pkgname-$pkgver"
@@ -27,4 +33,6 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+
+ find "$pkgdir"/usr/share/perl6/precomp -type f -exec env _pkgdir="$pkgdir" perl -pe 's/\Q$ENV{_pkgdir}//g' -i '{}' '+'
}
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..6f509831dbff
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,39 @@
+diff a/tools/build/Makefile-JVM.in b/tools/build/Makefile-JVM.in
+--- a/tools/build/Makefile-JVM.in
++++ b/tools/build/Makefile-JVM.in
+@@ -391,7 +391,7 @@ j-install: j-all tools/build/create-jvm-runner.pl tools/build/install-core-dist.
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/resources
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/bin
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/short
+- .@slash@$(J_RUNNER) tools/build/install-core-dist.pl
++ .@slash@$(J_RUNNER) tools/build/install-core-dist.pl $(DESTDIR)$(PERL6_LANG_DIR)
+ $(PERL) tools/build/create-jvm-runner.pl install "$(DESTDIR)" $(PREFIX) $(NQP_PREFIX) $(NQP_JARS)
+ $(PERL) tools/build/create-jvm-runner.pl install-debug "$(DESTDIR)" $(PREFIX) $(NQP_PREFIX) $(NQP_JARS)
+
+diff --git a/tools/build/Makefile-Moar.in b/tools/build/Makefile-Moar.in
+index 1e586d9..670b89c 100644
+--- a/tools/build/Makefile-Moar.in
++++ b/tools/build/Makefile-Moar.in
+@@ -246,7 +246,7 @@ m-install: m-all tools/build/create-moar-runner.pl tools/build/install-core-dist
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/resources
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/bin
+ $(MKPATH) $(DESTDIR)$(PERL6_LANG_DIR)/site/short
+- .@slash@$(M_RUNNER) tools/build/install-core-dist.pl
++ .@slash@$(M_RUNNER) tools/build/install-core-dist.pl $(DESTDIR)$(PERL6_LANG_DIR)
+ $(PERL) tools/build/create-moar-runner.pl "$(MOAR)" perl6.moarvm $(DESTDIR)$(PREFIX)/bin/perl6-m "$(PERL6_LANG_DIR)/runtime" "" "$(M_LIBPATH)" "$(PERL6_LANG_DIR)/lib" "$(PERL6_LANG_DIR)/runtime"
+ $(PERL) tools/build/create-moar-runner.pl "$(MOAR)" perl6-debug.moarvm $(DESTDIR)$(PREFIX)/bin/perl6-debug-m "$(PERL6_LANG_DIR)/runtime" "" "$(M_LIBPATH)" "$(PERL6_LANG_DIR)/lib" "$(PERL6_LANG_DIR)/runtime"
+ $(CHMOD) 755 $(DESTDIR)$(PREFIX)/bin/perl6-m$(M_BAT)
+diff --git a/tools/build/install-core-dist.pl b/tools/build/install-core-dist.pl
+index 0990b26..ba14b20 100644
+--- a/tools/build/install-core-dist.pl
++++ b/tools/build/install-core-dist.pl
+@@ -9,7 +9,8 @@ my %provides =
+ "experimental" => "lib/experimental.pm6",
+ ;
+
+-CompUnit::RepositoryRegistry.repository-for-name('perl').install(
++PROCESS::<$REPO> := CompUnit::RepositoryRegistry.repository-for-spec("inst#@*ARGS[0]");
++$*REPO.install(
+ Distribution.new(
+ name => "CORE",
+ auth => "perl",