summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2019-11-12 21:33:53 +0100
committerspider-mario2019-11-12 21:33:53 +0100
commitccd4e386dd13e5d5cfe689cd5c17186db4da3a23 (patch)
tree4ed39dac5833cd69dad34869accbd4330ef8e9ad
parent4b90427e63bc5b676b1a712c791e00cddbfaf5b9 (diff)
downloadaur-ccd4e386dd13e5d5cfe689cd5c17186db4da3a23.tar.gz
2019.07.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
-rw-r--r--stale-files.patch40
3 files changed, 61 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cdab43d2ec4..cdcfc7929b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rakudo
pkgdesc = Perl6 compiler for MoarVM
- pkgver = 2019.03.1
+ pkgver = 2019.07.1
pkgrel = 1
url = http://rakudo.org/
arch = i686
@@ -8,15 +8,16 @@ pkgbase = rakudo
groups = perl6
license = PerlArtistic
makedepends = perl>=5.8
- makedepends = git
- depends = nqp>=2019.03
+ depends = nqp>=2019.07.1
provides = rakudo-moarvm
provides = perl6
conflicts = rakudo-moarvm
replaces = rakudo-moarvm
options = !makeflags
- source = git+https://github.com/rakudo/rakudo.git#tag=2019.03.1
- sha512sums = SKIP
+ source = http://rakudo.org/downloads/rakudo/rakudo-2019.07.1.tar.gz
+ source = stale-files.patch
+ sha512sums = aedb26c8145eefb53471cf96a15b04f6759d43c68e11d7942c693ea2122583dd243e9dfe288d6fb11131eb2bd4e9d0c735986e241c5a35ca126dc7f10d6c4a8d
+ sha512sums = 0029f675ff757966024f84259af9d3fd67ccf1b7703356dcad801ab76da92cbb91bdd47e96f4ea4a14ba618cf4cb2f3717ab93bbfc8f40fe8238832b762684f6
pkgname = rakudo
diff --git a/PKGBUILD b/PKGBUILD
index 0882db38e8bd..e96cf1d2f687 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,37 @@
# Contributor: Marcin Karpezo <sirmacik at gmail dot com>
# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
pkgname=rakudo
-pkgver=2019.03.1
+pkgver=2019.07.1
pkgrel=1
pkgdesc="Perl6 compiler for MoarVM"
arch=('i686' 'x86_64')
url='http://rakudo.org/'
license=(PerlArtistic)
groups=('perl6')
-depends=("nqp>=2019.03")
-makedepends=('perl>=5.8' 'git')
+depends=("nqp>=$pkgver")
+makedepends=('perl>=5.8')
provides=('rakudo-moarvm' 'perl6')
replaces=('rakudo-moarvm')
conflicts=('rakudo-moarvm')
options=('!makeflags')
-source=("git+https://github.com/rakudo/rakudo.git#tag=$pkgver")
-sha512sums=('SKIP')
+source=("http://rakudo.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'stale-files.patch')
+sha512sums=('aedb26c8145eefb53471cf96a15b04f6759d43c68e11d7942c693ea2122583dd243e9dfe288d6fb11131eb2bd4e9d0c735986e241c5a35ca126dc7f10d6c4a8d'
+ '0029f675ff757966024f84259af9d3fd67ccf1b7703356dcad801ab76da92cbb91bdd47e96f4ea4a14ba618cf4cb2f3717ab93bbfc8f40fe8238832b762684f6')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < "$srcdir"/stale-files.patch
+}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
perl Configure.pl --prefix=/usr --backends=moar
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ install -Dm755 tools/install-dist.p6 "$pkgdir"/usr/bin/perl6-install-dist
}
diff --git a/stale-files.patch b/stale-files.patch
new file mode 100644
index 000000000000..2614d3b99fa7
--- /dev/null
+++ b/stale-files.patch
@@ -0,0 +1,40 @@
+diff --git a/tools/lib/NQP/Config/Rakudo.pm b/tools/lib/NQP/Config/Rakudo.pm
+index 90839c229..8c852c45d 100644
+--- a/tools/lib/NQP/Config/Rakudo.pm
++++ b/tools/lib/NQP/Config/Rakudo.pm
+@@ -510,17 +510,31 @@ sub clean_old_p6_libs {
+ my @files = qw(Actions.moarvm BOOTSTRAP.moarvm Compiler.moarvm Grammar.moarvm Metamodel.moarvm ModuleLoader.moarvm Ops.moarvm Optimizer.moarvm Pod.moarvm World.moarvm);
+
+ my @notes;
++ my @clean_rules;
+ for ( @files ) {
+ my $file = File::Spec->catdir( $lib_dir, $_ );
+ next unless -f $file;
+- push @notes, "Will remove: $file\n";
+- $self->{config}->{clean_old_p6_libs} .= "\t\$(RM_F) $file\n";
++ push @notes, "Will remove: $file\n";
++ push @clean_rules, "\t\$(RM_F) $file";
+ }
++ my $pp_pfx = $self->cfg('make_pp_pfx');
++
++ # Don't try removing if DESTDIR is defined for the running make. It is
++ # likely that a rakudo package is being built in a working environment.
++ $self->{config}->{clean_old_p6_libs} =
++ @clean_rules
++ ? ( "${pp_pfx}ifndef DESTDIR\n"
++ . join( "\n", @clean_rules )
++ . "\n${pp_pfx}endif\n" )
++ : "";
+ $self->note('NOTICE',
+ "Found stale files in $lib_dir.\n",
+ "These files were left by a previous install and cause breakage\n",
+- "in this Rakudo version. The files will be removed during install.\n",
+- "\n", @notes) if @notes;
++ "in this Rakudo version. The installtion will try to remove them\n",
++ "if possible.\n",
++ "\n",
++ @notes
++ ) if @notes;
+ }
+ }
+