summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-15 13:32:26 +0200
committerGoliathLabs2020-06-15 13:32:26 +0200
commit197cfff4b434255b8bc2c29e2e3a6f3bc90eac9f (patch)
tree6008f33130557b30cde8d87e9c5a2981fcb73c7f
parentcac89838f20becc1becf81e199e791c77b04edd8 (diff)
downloadaur-197cfff4b434255b8bc2c29e2e3a6f3bc90eac9f.tar.gz
Updated: PKGBUILD & electron8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 749d526c5582..23576441008c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rambox
pkgdesc = Free and Open Source messaging and emailing app that combines common web applications into one.
pkgver = 0.7.5
- pkgrel = 1
- url = http://rambox.pro/
+ pkgrel = 2
+ url = https://rambox.pro/
arch = i686
arch = x86_64
license = GPL3
@@ -11,7 +11,7 @@ pkgbase = rambox
makedepends = ruby
makedepends = npm
makedepends = sencha-cmd-6
- depends = electron
+ depends = electron8-bin
noextract = Rambox-0.7.5-x64.tar.gz
source = https://github.com/ramboxapp/community-edition/archive/0.7.5.tar.gz
source = https://github.com/ramboxapp/community-edition/releases/download/0.7.5/Rambox-0.7.5-linux-x64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index e2fc3495f058..cf3db42c15d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=rambox
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc='Free and Open Source messaging and emailing app that combines common web applications into one.'
arch=(i686 x86_64)
-depends=(electron)
+depends=(electron8-bin)
makedepends=(desktop-file-utils asar ruby npm sencha-cmd-6)
-url='http://rambox.pro/'
+url='https://rambox.pro/'
license=(GPL3)
source=("https://github.com/ramboxapp/community-edition/archive/$pkgver.tar.gz"
"https://github.com/ramboxapp/community-edition/releases/download/$pkgver/Rambox-$pkgver-linux-x64.tar.gz"
@@ -29,7 +29,9 @@ build() {
asar ef ../app.asar env.js
# install packages
- sed -Ei 's/\s+"electron": "[^"]+",//' package.json
+ #sed -Ei 's/\s+"electron": "[^"]+",//' package.json
+ sed -E -i -e 's|("electron": ").*"|\1'"$(cat '/usr/lib/electron8/version')"'"|' 'package.json'
+
npm install
# build