summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-10-05 19:39:01 +0200
committerPhilipp A2017-10-05 19:39:01 +0200
commita0ae3a2dbc20d7895a333c1b31b76e444ddc8a5e (patch)
treee0dd6d8b9c39ebd2ee9d1e1fd5b62ccdb612dfc8
parentebc0b17f937676c1a658b6ab53cb4a771a035bd7 (diff)
downloadaur-a0ae3a2dbc20d7895a333c1b31b76e444ddc8a5e.tar.gz
v0.5.13
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fbe41639856..cfebe921b95d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Sep 20 13:19:49 UTC 2017
+# Thu Oct 5 17:38:48 UTC 2017
pkgbase = rambox
pkgdesc = Free and Open Source messaging and emailing app that combines common web applications into one.
- pkgver = 0.5.12
- pkgrel = 3
+ pkgver = 0.5.13
+ pkgrel = 1
url = http://rambox.pro/
arch = i686
arch = x86_64
@@ -14,14 +14,14 @@ pkgbase = rambox
makedepends = npm
makedepends = sencha-cmd-6
depends = electron
- noextract = Rambox-0.5.12-x64.tar.gz
- source = 0.5.12.tar.gz::https://github.com/saenzramiro/rambox/archive/d269740a76c97537a4cf2095483389abf88d44ed.tar.gz
- source = https://github.com/saenzramiro/rambox/releases/download/0.5.12/Rambox-0.5.12-x64.tar.gz
+ noextract = Rambox-0.5.13-x64.tar.gz
+ source = https://github.com/saenzramiro/rambox/archive/0.5.13.tar.gz
+ source = https://github.com/saenzramiro/rambox/releases/download/0.5.13/Rambox-0.5.13-x64.tar.gz
source = context-menu.patch::https://github.com/flying-sheep/rambox/commit/2109de0825058a3ee9c0a09a603520b8e7c09744.diff
source = rambox.desktop
source = rambox.js
- sha256sums = 6345764adf3dfec2651d819d76d5d0cf2c4413f3a2614c426fa596db8658666d
- sha256sums = f41049ef2082ce5e8f34463ba42ee1cc953e46cf4828fdd0bd1e9f1d5468601d
+ sha256sums = 7d14d5da8d9c13d6253ad69142ea912c496296600afd4ad6c6bec89b967941f0
+ sha256sums = eb506db7e1b412dbdbf9e0ab69686cc10f60e3c7f2e338db5c477e45eb05d198
sha256sums = 953d6b589b7acee32d78da6c533e851bc90a11182b775388ddcf158decf66c8e
sha256sums = 61ad70a929c402e24c79b8868208310f9b3c4d7801db2b791af38293231ee524
sha256sums = 3b5ed6f04eea66f239b5ae56ea1ff9e47de156cd38bb54ebc46541daba6091b6
diff --git a/PKGBUILD b/PKGBUILD
index 9fd8b35ebeb2..e899566fd48b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=rambox
-pkgver=0.5.12
-_relver=0.5.12 # for a release tarball containing env.js
-pkgrel=3
-_commit=d269740a76c97537a4cf2095483389abf88d44ed # because the 0.5.12 tag is fucked up
+pkgver=0.5.13
+_relver=0.5.13 # for a release tarball containing env.js
+pkgrel=1
pkgdesc='Free and Open Source messaging and emailing app that combines common web applications into one.'
arch=(i686 x86_64)
depends=(electron)
makedepends=(desktop-file-utils asar ruby npm sencha-cmd-6)
url='http://rambox.pro/'
license=('GPL3')
-source=("$pkgver.tar.gz::https://github.com/saenzramiro/$pkgname/archive/$_commit.tar.gz"
+source=("https://github.com/saenzramiro/$pkgname/archive/$pkgver.tar.gz"
"https://github.com/saenzramiro/$pkgname/releases/download/$_relver/Rambox-$_relver-x64.tar.gz"
"context-menu.patch::https://github.com/flying-sheep/$pkgname/commit/2109de0825058a3ee9c0a09a603520b8e7c09744.diff"
"$pkgname.desktop" "$pkgname.js")
-sha256sums=('6345764adf3dfec2651d819d76d5d0cf2c4413f3a2614c426fa596db8658666d'
- 'f41049ef2082ce5e8f34463ba42ee1cc953e46cf4828fdd0bd1e9f1d5468601d'
+sha256sums=('7d14d5da8d9c13d6253ad69142ea912c496296600afd4ad6c6bec89b967941f0'
+ 'eb506db7e1b412dbdbf9e0ab69686cc10f60e3c7f2e338db5c477e45eb05d198'
'953d6b589b7acee32d78da6c533e851bc90a11182b775388ddcf158decf66c8e'
'61ad70a929c402e24c79b8868208310f9b3c4d7801db2b791af38293231ee524'
'3b5ed6f04eea66f239b5ae56ea1ff9e47de156cd38bb54ebc46541daba6091b6')
@@ -26,7 +25,7 @@ build() {
# retrieve env.js
cd "$srcdir"
tar xOf "Rambox-$_relver-x64.tar.gz" "Rambox-$_relver/resources/app.asar" >app.asar
- cd "$pkgname-$_commit"
+ cd "$pkgname-$pkgver"
asar ef ../app.asar env.js
# context menu patch
@@ -42,7 +41,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$_commit"
+ cd "$srcdir/$pkgname-$pkgver"
install -d "$pkgdir/usr/lib"
cp -r 'build/production/Rambox' "$pkgdir/usr/lib/rambox"