summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-09-07 12:14:21 +0200
committerPhilipp A2017-09-07 12:14:21 +0200
commita0f9ef098fc86be95cc20cd9a03e5ee709b289e6 (patch)
tree85ae2888121522ed6e50ddc87770fb0c7b0925d5
parent2947cb4f7d0eb99b39e0ee868becc90f3be7c1d6 (diff)
downloadaur-a0f9ef098fc86be95cc20cd9a03e5ee709b289e6.tar.gz
use npm
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03a3fc1ee59f..da4d2a2190da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rambox
pkgdesc = Free and Open Source messaging and emailing app that combines common web applications into one.
pkgver = 0.5.12
- pkgrel = 1
+ pkgrel = 2
url = http://rambox.pro/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = rambox
makedepends = desktop-file-utils
makedepends = asar
makedepends = ruby
- makedepends = yarn
+ makedepends = npm
makedepends = sencha-cmd-6
depends = electron
noextract = Rambox-0.5.12-x64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7241745b4530..416f2c980c7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=rambox
pkgver=0.5.12
_relver=0.5.12 # for a release tarball containing env.js
-pkgrel=1
+pkgrel=2
pkgdesc='Free and Open Source messaging and emailing app that combines common web applications into one.'
arch=(i686 x86_64)
depends=(electron)
-makedepends=(desktop-file-utils asar ruby yarn sencha-cmd-6)
+makedepends=(desktop-file-utils asar ruby npm sencha-cmd-6)
url='http://rambox.pro/'
license=('GPL3')
source=("https://github.com/saenzramiro/$pkgname/archive/$pkgver.tar.gz"
@@ -33,10 +33,10 @@ build() {
# install packages
sed -Ei 's/\s+"electron": "[^"]+",//' package.json
- yarn
+ npm install
# build
- yarn run sencha:compile
+ npm run sencha:compile
sed -i "s/require('electron-is-dev')/false/" 'build/production/Rambox/electron/main.js'
}