summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc.magyar2017-11-08 03:43:57 -0600
committerc.magyar2017-11-08 03:43:57 -0600
commitb451feec4995f44ec7c86cb60f58441bd60d39bb (patch)
treeb944d7d99f7f4dfaea40cfd3f26d1e80689ea45d
parentda234d67c553f27c3063ddfe2d171003023d664a (diff)
downloadaur-b451feec4995f44ec7c86cb60f58441bd60d39bb.tar.gz
v1.1.2 - now with man page!
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a300e6a2d41..2988c60d9cbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ramroot
- pkgdesc = Load root and /boot partitions to RAM during boot
- pkgver = 1.1.1
+ pkgdesc = Load root filesystem completely to RAM during boot
+ pkgver = 1.1.2
pkgrel = 1
url = https://github.com/arcmags/ramroot
arch = any
license = GPL
depends = sudo
- source = https://github.com/arcmags/ramroot/1.1.0.tar.gz
- md5sums = f71f0653947cd5f6f88ab4e82df6767a
+ source = https://github.com/arcmags/ramroot/1.1.2.tar.gz
+ md5sums = c908873e558f31c5ea3e5afc07c1e997
pkgname = ramroot
diff --git a/PKGBUILD b/PKGBUILD
index 08ad6ce6d1e1..014d1fcfebd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Chris Magyar <c.magyar.ec@gmail.com>
pkgname=ramroot
-pkgver=1.1.1
+pkgver=1.1.2
pkgrel=1
-pkgdesc="Load root and /boot partitions to RAM during boot"
+pkgdesc="Load root filesystem completely to RAM during boot"
arch=('any')
url="https://github.com/arcmags/$pkgname"
license=('GPL')
depends=('sudo')
conflicts=('liveroot')
install=ramroot.install
-source=("$pkgname-$pkgver.tar.gz.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('f71f0653947cd5f6f88ab4e82df6767a')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+md5sums=('c908873e558f31c5ea3e5afc07c1e997')
package() {
cd "$pkgname-$pkgver"
@@ -18,5 +18,8 @@ package() {
"$pkgdir/usr/lib/ramroot/hooks/ramroot"
install -D -m644 ./lib/install/ramroot \
"$pkgdir/usr/lib/ramroot/install/ramroot"
- install -D -m755 ./ramroot "$pkgdir/usr/bin/ramroot"
+ install -D -m755 ./ramroot \
+ "$pkgdir/usr/bin/ramroot"
+ install -D -m644 ./lib/man/ramroot.8 \
+ "$pkgdir/usr/share/man/man8/ramroot.8"
}