summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc.magyar2017-10-31 17:39:37 -0500
committerc.magyar2017-10-31 17:39:37 -0500
commitc9e214a868ebf777926484a48bed1203bf5f1d0c (patch)
tree61795db3cc9b7124047396363a78ce4e87b2871d
downloadaur-c9e214a868ebf777926484a48bed1203bf5f1d0c.tar.gz
initial AUR commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
-rw-r--r--ramroot.install6
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a63dcd51690
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ramroot
+ pkgdesc = load root and /boot partitions to RAM during boot
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/arcmags/ramroot
+ arch = any
+ license = GPL
+ depends = sudo
+ source = https://github.com/arcmags/ramroot/1.1.0.tar.gz
+ md5sums = 38af1211ce52a41dd0d3548c43a5d47b
+
+pkgname = ramroot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8195b1cb3a28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Magyar <c.magyar.ec@gmail.com>
+pkgname=ramroot
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="load root and /boot partitions to RAM during boot"
+arch=('any')
+url="https://github.com/arcmags/ramroot"
+license=('GPL')
+depends=('sudo')
+conflicts=('liveroot')
+install=ramroot.install
+source=("https://github.com/arcmags/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('38af1211ce52a41dd0d3548c43a5d47b')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/ramroot/hooks"
+ install -m644 ./lib/hooks/ramroot \
+ "$pkgdir/usr/lib/ramroot/hooks/ramroot"
+
+ mkdir -p "$pkgdir/usr/lib/ramroot/install"
+ install -m644 ./lib/install/ramroot \
+ "$pkgdir/usr/lib/ramroot/install/ramroot"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 ./ramroot "$pkgdir/usr/bin/ramroot"
+}
diff --git a/ramroot.install b/ramroot.install
new file mode 100644
index 000000000000..8ee8bcbff090
--- /dev/null
+++ b/ramroot.install
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+# ensure ramroot is disabled before removing:
+pre_remove() {
+ /usr/bin/ramroot -D
+}