summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc.magyar2017-11-01 22:48:27 -0500
committerc.magyar2017-11-01 22:48:27 -0500
commite2863e4bc2981e670042b08c5ac1aac7bb063cd2 (patch)
tree3380e6c79b2e6be380de673d9050ffe444a6824a
parentc02ba4da1f45976ff6cb9d6eede1ec938d80e433 (diff)
downloadaur-e2863e4bc2981e670042b08c5ac1aac7bb063cd2.tar.gz
cleaned up PKGBUILD
-rw-r--r--PKGBUILD18
-rw-r--r--ramroot.install2
2 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7ff8a3436e5..08ad6ce6d1e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,21 @@
pkgname=ramroot
pkgver=1.1.1
pkgrel=1
-pkgdesc="load root and /boot partitions to RAM during boot"
+pkgdesc="Load root and /boot partitions to RAM during boot"
arch=('any')
-url="https://github.com/arcmags/ramroot"
+url="https://github.com/arcmags/$pkgname"
license=('GPL')
depends=('sudo')
conflicts=('liveroot')
install=ramroot.install
-source=("https://github.com/arcmags/$pkgname/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz.tar.gz::$url/archive/$pkgver.tar.gz")
md5sums=('f71f0653947cd5f6f88ab4e82df6767a')
package() {
cd "$pkgname-$pkgver"
-
- mkdir -p "$pkgdir/usr/lib/ramroot/hooks"
- install -m644 ./lib/hooks/ramroot \
+ install -D -m644 ./lib/hooks/ramroot \
"$pkgdir/usr/lib/ramroot/hooks/ramroot"
-
- mkdir -p "$pkgdir/usr/lib/ramroot/install"
- install -m644 ./lib/install/ramroot \
+ install -D -m644 ./lib/install/ramroot \
"$pkgdir/usr/lib/ramroot/install/ramroot"
-
- mkdir -p "$pkgdir/usr/bin"
- install -m755 ./ramroot "$pkgdir/usr/bin/ramroot"
+ install -D -m755 ./ramroot "$pkgdir/usr/bin/ramroot"
}
diff --git a/ramroot.install b/ramroot.install
index 8d5d5b890238..65b1ba82ed4f 100644
--- a/ramroot.install
+++ b/ramroot.install
@@ -1,6 +1,6 @@
#!/bin/bash
-# ensure ramroot is disabled before removing:
+# ensure ramroot is fully removed before uninstalling:
pre_remove() {
/usr/bin/ramroot -R
}