summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2016-01-26 19:50:20 +0300
committerAnton Leontiev2016-01-26 19:50:20 +0300
commit167f5d92fe5870028cf37b73dc0ae3c95f4edac1 (patch)
treed8b062e52a173665df1bfc5fb1da30dd313f242a
downloadaur-167f5d92fe5870028cf37b73dc0ae3c95f4edac1.tar.gz
Initial v3.5.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--Makefile21
-rw-r--r--PKGBUILD33
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8cf19086feb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 16:49:31 UTC 2016
+pkgbase = ramsmp
+ pkgdesc = Open source memory and cache benchmark (SMP version)
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = http://alasir.com/software/ramspeed/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = custom
+ depends = glibc
+ source = http://sources.buildroot.net/ramsmp-3.5.0.tar.gz
+ source = Makefile
+ md5sums = c26b32c752c603e17c28a1cab4348682
+ md5sums = 4069edc026df25b6d0a609a552b3a469
+
+pkgname = ramsmp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..04460d13c768
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+SOURCES := ramsmp.c
+
+ifeq ($(CARCH),i686)
+SOURCES += $(wildcard i386/*.s) $(wildcard i386/cpuinfo/*.s)
+CPPFLAGS += -DI386_ASM
+else ifeq ($(CARCH),x86_64)
+SOURCES += $(wildcard amd64/*.s)
+CPPFLAGS += -DAMD64_ASM
+else
+SOURCES += fltmem.c intmem.c fltmark.c intmark.c
+endif
+
+CPPFLAGS += -DLinux
+CFLAGS += -O3
+
+ramsmp: $(SOURCES)
+ echo $(CARCH)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+clean:
+ rm -f *.o ramsmp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edf6815c2d15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Anton Leontiev <scileont /at/ gmail.com>
+pkgname=ramsmp
+pkgver=3.5.0
+pkgrel=1
+pkgdesc='Open source memory and cache benchmark (SMP version)'
+arch=('i686' 'x86_64' 'armv7h')
+depends=('glibc')
+license=('custom')
+url='http://alasir.com/software/ramspeed/'
+# Original source is http://www.alasir.com/software/ramspeed/$pkgname-$pkgver.tar.gz
+# but it may not work.
+source=(http://sources.buildroot.net/$pkgname-$pkgver.tar.gz Makefile)
+md5sums=('c26b32c752c603e17c28a1cab4348682'
+ '4069edc026df25b6d0a609a552b3a469')
+
+prepare() {
+ cp Makefile $pkgname-$pkgver/
+ sed -i "s:see the manual for details:see /usr/share/doc/$pkgname/README:" \
+ $pkgname-$pkgver/$pkgname.c
+}
+
+build() {
+ cd $pkgname-$pkgver
+ export CARCH
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENCE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+}