summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorburt1iband2016-03-24 19:27:36 -0600
committerburt1iband2016-03-24 19:27:36 -0600
commit9df80414aa100f72445721589d3d2af05e556452 (patch)
tree096f4bb23395e5d9c7432c8897b63504e4111e8b
downloadaur-9df80414aa100f72445721589d3d2af05e556452.tar.gz
Initial commit starting around ran-0.5.0
Hopefully this will be useful. Currently the .install file does not add the user's ~/.fluxable dir or config file when missing as does the bash installer/to fix pronto.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--ran.install33
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f04817adc1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ran-git
+ pkgdesc = record audio notes: a front end for sox written in bash
+ pkgver = 6.f67d3cc
+ pkgrel = 1
+ url = https://github.com/burt1iband/ran
+ install = ran.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bash
+ depends = bc
+ depends = sox
+ optdepends = notification-daemon
+ optdepends = orca
+ optdepends = speakup
+ provides = ran
+ conflicts = ran
+ source = git+https://github.com/burt1iband/ran.git
+ md5sums = SKIP
+
+pkgname = ran-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..004dfaa05aa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+### Arch_Linux PKGBUILD for fluxable-newmenu
+## Maintainer: B.H. <es_vinux@vinuxproject.org>
+## Contributer StormDragon <stormdragon2976@gmail.com>
+
+pkgname=ran-git
+_pkgname=ran
+pkgver=6.f67d3cc
+pkgrel=1
+pkgdesc="record audio notes: a front end for sox written in bash"
+arch=('any')
+url="https://github.com/burt1iband/ran"
+license=('GPL')
+source=("git+${url}.git")
+depends=('bash' 'bc' 'sox')
+optdepends=('notification-daemon' 'orca' 'speakup')
+makedepends=('git')
+provides=('ran')
+conflicts=('ran')
+install=${_pkgname}.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+cd "${srcdir}/${_pkgname}"
+ install -d "$pkgdir/usr/bin"
+ install -m 755 $_pkgname $pkgdir/usr/bin/
+ install -d "$pkgdir/etc/fluxable"
+ install -m 644 fluxable.conf.org ${pkgdir}/etc/fluxable/
+ install -d "$pkgdir/usr/share/doc/ran"
+ install -m 644 change-log.txt $pkgdir/usr/share/doc/ran/
+ install -d "$pkgdir/usr/share/man/man1"
+ install -m 644 ran.1.gz $pkgdir/usr/share/man/man1/
+}
diff --git a/ran.install b/ran.install
new file mode 100644
index 000000000000..98b7a11aa993
--- /dev/null
+++ b/ran.install
@@ -0,0 +1,33 @@
+## ran.install
+
+## Update defaults for users who have not customized
+inst_sysconf() {
+if ! [ -f /etc/fluxable/fluxable.conf ]; then
+ cp /etc/fluxable/fluxable.conf.org /etc/fluxable/fluxable.conf
+ fi
+ }
+
+## Tell the user what's going on and what to expect.
+post_inst_msg() {
+ echo "If you ever trash your ~/.fluxable/fluxable.conf file
+a sample configuration file has been installed for you
+to /etc/fluxable with a .org extension."
+echo
+echo "To use ran open a terminal or tty console, type ran, or ran some-filename,
+and recording will start. The file's extension will be added by ran.
+Control cstops the recording. Recordings live in ~/Audio/au_notes.
+To see a help message type ran -h, or
+man ran for more detailed information."
+ }
+
+post_install() {
+inst_sysconf
+
+post_inst_msg
+ }
+
+post_upgrade() {
+inst_sysconf
+
+post_inst_msg
+ }