summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Giebert2023-04-11 15:46:37 +0200
committerDominic Giebert2023-04-11 15:46:37 +0200
commit52270adc2df924c805eb7224c026d1bc0bbd87dd (patch)
treea1ddb8d7d762982072f39ef028bc8348bb30fee8
parent91d3787ae017ba4689f943358c2c572162986ea1 (diff)
downloadaur-52270adc2df924c805eb7224c026d1bc0bbd87dd.tar.gz
Add build stage
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb55e1731edf..60e5f1293c44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rancher-desktop
pkgdesc = Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://rancherdesktop.io/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index b01c004668ae..ab2dfb6a2271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rancher-desktop
pkgdesc='Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop'
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
license=('Apache')
url='https://rancherdesktop.io/'
@@ -23,7 +23,7 @@ _ensure_local_nvm() {
prepare() {
_ensure_local_nvm
- nvm install 16.19.0
+ nvm install 16.20.0
cd "${pkgname}-${pkgver}"
@@ -51,6 +51,7 @@ build() {
rm packaging/linux/flatpak.yaml
# https://github.com/rancher-sandbox/rancher-desktop#how-to-run
npm install
+ npm run build
npm run package
}