summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Giebert2023-03-29 09:30:09 +0200
committerDominic Giebert2023-03-29 09:30:09 +0200
commit91d3787ae017ba4689f943358c2c572162986ea1 (patch)
tree1c953371b73d7e725a2d235837001a4fa6f65012
parentaf651bff7a0610e9fdadb0944044f97f81cb3a37 (diff)
downloadaur-91d3787ae017ba4689f943358c2c572162986ea1.tar.gz
Bump to 1.8.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ca28a405539..cb55e1731edf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rancher-desktop
pkgdesc = Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop
- pkgver = 1.7.0
+ pkgver = 1.8.1
pkgrel = 1
url = https://rancherdesktop.io/
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = rancher-desktop
provides = kubectl
provides = nerdctl
provides = limactl
- source = https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v1.7.0.tar.gz
- sha256sums = a7b6c376a05d8d983c8177476e605212d7e4656b0ae117cd7aaa4a9a9d7552ff
+ source = https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v1.8.1.tar.gz
+ sha256sums = 7ed1d0b7d2aa1fbcbce4da02ba4eda14f98d4267110ddbfbf59c25545f8b9c70
pkgname = rancher-desktop
diff --git a/PKGBUILD b/PKGBUILD
index bee35aa8f671..b01c004668ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rancher-desktop
pkgdesc='Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop'
-pkgver=1.7.0
+pkgver=1.8.1
pkgrel=1
arch=('x86_64')
license=('Apache')
@@ -12,7 +12,7 @@ makedepends=('npm' 'nvm' 'nodejs' 'imagemagick' 'go')
provides=('rancher-desktop' 'docker' 'helm' 'kubectl' 'nerdctl' 'limactl')
depends=('qemu')
source=("https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('a7b6c376a05d8d983c8177476e605212d7e4656b0ae117cd7aaa4a9a9d7552ff')
+sha256sums=('7ed1d0b7d2aa1fbcbce4da02ba4eda14f98d4267110ddbfbf59c25545f8b9c70')
# https://wiki.archlinux.org/title/Node.js_package_guidelines#Using_nvm
_ensure_local_nvm() {
@@ -27,7 +27,7 @@ prepare() {
cd "${pkgname}-${pkgver}"
- sed -i "s|childProcess.execFileSync('git', \['describe', '--tags'\]).toString().trim()|'v${pkgver}'|g" scripts/build.ts
+ sed -i "s|childProcess.execFileSync('git', \['describe', '--tags'\]).toString().trim()|'v${pkgver}'|g" scripts/package.ts
# Uncomment if you want to have the tray functionality
# sed -i "/if (os.platform() === 'linux' \&\& !settings.isFirstRun()) {\$/,+2d" background.ts
@@ -51,7 +51,7 @@ build() {
rm packaging/linux/flatpak.yaml
# https://github.com/rancher-sandbox/rancher-desktop#how-to-run
npm install
- npm run build
+ npm run package
}
package() {