summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Giebert2022-06-08 22:21:56 +0200
committerDominic Giebert2022-06-08 22:21:56 +0200
commit9aa37aeb603174402c6ea4cdb545bc2dee33ed96 (patch)
treefe9fb53b85818fa90bec2dfbf00f8475cf3c5d01
parentaeee16324be87609fc8de4b2d066c5714bcee0e6 (diff)
downloadaur-9aa37aeb603174402c6ea4cdb545bc2dee33ed96.tar.gz
Bump to v1.4.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57931d3edae5..71c9d194d7b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rancher-desktop
pkgdesc = Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop
- pkgver = 1.3.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://rancherdesktop.io/
arch = x86_64
@@ -11,16 +11,13 @@ pkgbase = rancher-desktop
makedepends = imagemagick
makedepends = go
depends = qemu
- optdepends = kubectl: Kubernetes control, can be downloaded from settings
- optdepends = nerdctl-bin: Docker-compatible CLI for containerd
- optdepends = helm: for Apps section, only useful if your deploy uses helm or plan to use it
provides = rancher-desktop
provides = docker
provides = helm
provides = kubectl
provides = nerdctl
provides = limactl
- source = https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v1.3.0.tar.gz
- sha256sums = c50001a79510bf95c2b700e1d07ace26ae09eb29f5a6077360a9cb089b2d810c
+ source = https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v1.4.1.tar.gz
+ sha256sums = a4209f3007ed59814f28e6d89961a013d166595c0158a517e80ea4c9f20f6314
pkgname = rancher-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 65f5c9a87b29..26807fa15375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,16 @@
pkgname=rancher-desktop
pkgdesc='Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop'
-pkgver=1.3.0
+pkgver=1.4.1
pkgrel=1
arch=('x86_64')
license=('Apache')
url='https://rancherdesktop.io/'
makedepends=('npm' 'nvm' 'nodejs' 'imagemagick' 'go')
-optdepends=('kubectl: Kubernetes control, can be downloaded from settings'
- 'nerdctl-bin: Docker-compatible CLI for containerd'
- 'helm: for Apps section, only useful if your deploy uses helm or plan to use it')
provides=('rancher-desktop' 'docker' 'helm' 'kubectl' 'nerdctl' 'limactl')
depends=('qemu')
source=("https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('c50001a79510bf95c2b700e1d07ace26ae09eb29f5a6077360a9cb089b2d810c')
+sha256sums=('a4209f3007ed59814f28e6d89961a013d166595c0158a517e80ea4c9f20f6314')
# https://wiki.archlinux.org/title/Node.js_package_guidelines#Using_nvm
_ensure_local_nvm() {
@@ -26,7 +23,7 @@ _ensure_local_nvm() {
prepare() {
_ensure_local_nvm
- nvm install 16.14.0
+ nvm install 16.15.1
cd "${pkgname}-${pkgver}"