summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Giebert2021-12-20 14:08:53 +0100
committerDominic Giebert2021-12-20 14:08:53 +0100
commit9b099201c9ef048ba9a517033e5fa70ee1f27880 (patch)
tree35a5bf3482875974161908c846942d6ee52bccb5
parent7b48574533ca9e0dfef494f8a92d349b658763a2 (diff)
downloadaur-9b099201c9ef048ba9a517033e5fa70ee1f27880.tar.gz
Update SRCINFO
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD3
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3685d513664c..347d4fe14f4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rancher-desktop
pkgdesc = Rancher Desktop is an open-source project to bring Kubernetes and container management to the desktop
- pkgver = 0.6.1
- pkgrel = 3
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://rancherdesktop.io/
arch = x86_64
license = Apache
makedepends = npm
+ makedepends = nvm
makedepends = nodejs
- makedepends = git
depends = qemu
optdepends = kubectl: Kubernetes control, can be downloaded from settings
optdepends = nerdctl-bin: Docker-compatible CLI for containerd
@@ -18,8 +18,7 @@ pkgbase = rancher-desktop
provides = kim
provides = kubectl
provides = nerdctl
- conflicts = rancher-desktop-git
- source = rancher-desktop-0.6.1::git+https://github.com/rancher-sandbox/rancher-desktop.git#branch=main
- sha256sums = SKIP
+ source = https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v0.7.0.tar.gz
+ sha256sums = e6daa58f5341ea9001d39dffee127682482e6d9f41b4ebfa53c269977baa2a15
pkgname = rancher-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 40ccf324e199..9dba57ec5f1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ makedepends=('npm' 'nvm' 'nodejs')
optdepends=('kubectl: Kubernetes control, can be downloaded from settings'
'nerdctl-bin: Docker-compatible CLI for containerd'
'helm: for Apps section, only useful if your deploy uses helm or plan to use it')
+provides=('rancher-desktop' 'docker' 'helm' 'kim' 'kubectl' 'nerdctl')
depends=('qemu')
source=("https://github.com/rancher-sandbox/rancher-desktop/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('e6daa58f5341ea9001d39dffee127682482e6d9f41b4ebfa53c269977baa2a15')
@@ -70,4 +71,4 @@ package() {
# Creating the symlink for better usage
install -d "$pkgdir"/usr/bin/
ln -sf /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
-} \ No newline at end of file
+}