summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Dellinger2020-09-20 22:40:42 +0200
committerJonas Dellinger2020-09-20 22:43:07 +0200
commitbcd84f9df95034590cb70cbc694b44e0fc43d5be (patch)
tree32082c98ea48060306eee9ee21f56b16ddeeea43
parent0ba5ac7ee33e7290346d3bc64d08adcbed732765 (diff)
downloadaur-bcd84f9df95034590cb70cbc694b44e0fc43d5be.tar.gz
Update: 3.0.2 and added script for sha256sums
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rwxr-xr-xprint-sums.sh25
3 files changed, 32 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b9b63aa2d32..f4379a70e080 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rancher-k3d-bin
pkgdesc = Little helper to run Rancher Labs k3s in Docker
- pkgver = 3.0.1
+ pkgver = 3.0.2
pkgrel = 1
url = https://github.com/rancher/k3d
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = rancher-k3d-bin
license = MIT
provides = k3d
conflicts = rancher-k3d-beta-bin
- source = rancher-k3d-bin-3.0.1-amd64::https://github.com/rancher/k3d/releases/download/v3.0.1/k3d-linux-amd64
- sha256sums = e773d3a8377b6562d2cf29e7683c89ecc03f5843990c1853b810ca1c656aeb2e
+ source = rancher-k3d-bin-3.0.2-amd64::https://github.com/rancher/k3d/releases/download/v3.0.2/k3d-linux-amd64
+ sha256sums = 4751acfdb6a90a2f39f97293c862835aa863744f4c8ac4654168527e0365f109
pkgname = rancher-k3d-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7c53dc3d227b..16624c6258d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonas Dellinger <jonas@dellinger.dev>
pkgname="rancher-k3d-bin"
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc='Little helper to run Rancher Labs k3s in Docker'
arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
@@ -10,9 +10,9 @@ provides=("k3d")
conflicts=("rancher-k3d-beta-bin")
case "${CARCH}" in
- x86_64) _CARCH=amd64 && sha256sums=('e773d3a8377b6562d2cf29e7683c89ecc03f5843990c1853b810ca1c656aeb2e');;
- aarch64) _CARCH=arm64 && sha256sums=('a861bf5cab4376706c69836f81688eb24c2d7775a45de40cbb0612e7631e2037');;
- arm*) _CARCH=arm && sha256sums=('75a9ef3e0c67f9d5f950277932f68432424b3d44da1e3939270fdeda34b0ab7d');;
+ x86_64) _CARCH=amd64 && sha256sums=('4751acfdb6a90a2f39f97293c862835aa863744f4c8ac4654168527e0365f109');;
+ aarch64) _CARCH=arm64 && sha256sums=('714469cc62d4121015d4510677fe9b6b6208fa11f3f90ac07efc8da3d9db22fd');;
+ arm*) _CARCH=arm && sha256sums=('6466cdbe74603a3d44056ba84c944175a16f0e1048d816f7272c1ad6028b6bda');;
esac
source=("${pkgname}-${pkgver}-${_CARCH}::https://github.com/rancher/k3d/releases/download/v$pkgver/k3d-linux-${_CARCH}")
diff --git a/print-sums.sh b/print-sums.sh
new file mode 100755
index 000000000000..85451779ce55
--- /dev/null
+++ b/print-sums.sh
@@ -0,0 +1,25 @@
+#!/bin/bash
+
+set -e
+
+pkgver="$1"
+if [ -z "$pkgver" ]; then
+ echo "No pkgver set"
+ exit 1;
+fi
+
+file=`mktemp`
+
+function download_and_print_sum() {
+ echo "Downloading for $arch ..."
+ curl -sL "https://github.com/rancher/k3d/releases/download/v$pkgver/k3d-linux-${arch}" --output "$file"
+ sum=`sha256sum $file`
+ echo "==> $sum"
+}
+
+arch="amd64"
+download_and_print_sum
+arch="arm64"
+download_and_print_sum
+arch="arm"
+download_and_print_sum