summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey M2019-11-03 19:48:55 +0300
committerSergey M2019-11-03 20:27:47 +0300
commitfa8af3dc714626cad462942585333b7fb4afba42 (patch)
treeba396db81afd87c2c8212074f23e8fefb1ad4306
downloadaur-fa8af3dc714626cad462942585333b7fb4afba42.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b9a5093c0dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = random-wallpaper
+ pkgdesc = Changes the desktop wallpaper to random from the site wallhaven.cc
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/tz4678/random-wallpaper
+ arch = any
+ license = MIT
+ depends = jq
+ source = git+https://github.com/tz4678/random-wallpaper.git
+ md5sums = SKIP
+
+pkgname = random-wallpaper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..213f1370a78e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+/random-wallpaper
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7db20fcf489f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Sergey M <tz4678@gmail.com>
+pkgname=random-wallpaper
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Changes the desktop wallpaper to random from the site wallhaven.cc'
+arch=('any')
+url='https://github.com/tz4678/random-wallpaper'
+license=('MIT')
+depends=('jq')
+source=('git+https://github.com/tz4678/random-wallpaper.git')
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm644 $pkgname.service $pkgdir/usr/lib/systemd/system/$pkgname.service
+ install -Dm644 $pkgname.timer $pkgdir/usr/lib/systemd/system/$pkgname.timer
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}