summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Kostiuchenko2015-07-06 17:08:51 +0200
committerDmytro Kostiuchenko2015-07-06 17:08:51 +0200
commitdb4e324bea63a843482ce7c5944de3dfbc90dc05 (patch)
tree3a756d5b53bb61058d6cf9c36919a90ec0b293cd
downloadaur-db4e324bea63a843482ce7c5944de3dfbc90dc05.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
3 files changed, 69 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a7137bdb8973
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = randrctl-git
+ pkgdesc = Lightweight profile based screen manager for X
+ pkgver = r28.7297e20
+ pkgrel = 1
+ url = http://github.com/edio/randrctl
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = python
+ depends = xorg-xrandr
+ optdepends = bash-completion
+ provides = randrctl
+ conflicts = randrctl
+ source = git+https://github.com/edio/randrctl.git
+
+pkgname = randrctl-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b54435deaaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = randrctl-git
+ pkgdesc = Lightweight profile based screen manager for X
+ pkgver = r28.7297e20
+ pkgrel = 1
+ url = http://github.com/edio/randrctl
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = python
+ depends = xorg-xrandr
+ optdepends = bash-completion
+ provides = randrctl
+ conflicts = randrctl
+ source = git+https://github.com/edio/randrctl.git
+ md5sums = SKIP
+
+pkgname = randrctl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acd5130a8a8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gabriel Peixoto <gabrielrcp@gmail.com>
+
+_gitname=randrctl
+pkgname=$_gitname-git
+pkgdesc="Lightweight profile based screen manager for X"
+pkgver=r28.7297e20
+pkgrel=1
+arch=('any')
+url="http://github.com/edio/randrctl"
+license=('GPLv3')
+makedepends=('git')
+depends=('python' 'xorg-xrandr')
+optdepends=('bash-completion')
+source=('git+https://github.com/edio/randrctl.git')
+md5sums=('SKIP')
+provides=("$_gitname")
+conflicts=("$_gitname")
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_gitname
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 etc/randrctl/config.ini "$pkgdir/etc/randrctl/config.ini"
+ install -Dm644 etc/randrctl/profiles/examples/default "$pkgdir/etc/randrctl/profiles/examples/default"
+ install -Dm644 etc/completion/randrctl.zsh "$pkgdir/usr/share/zsh/site-functions/_randrctl"
+ install -Dm644 etc/completion/randrctl.bash "$pkgdir/usr/share/bash-completion/completions/randrctl"
+ install -Dm644 etc/udev/rules.d/99-randrctl.rules "$pkgdir/usr/lib/udev/rules.d/99-randrctl.rules"
+}
+
+# vim:set ts=2 sw=2 et: