summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-23 15:34:53 -0500
committerLuis Martinez2023-03-23 15:34:53 -0500
commit77134c547ba5e7055fd3ef87dc2466a929466428 (patch)
treeb0271ffe91d3c5ea93710c8c7b46ef67c25ace5b
parentfc4c3b8c2fbd91af1a8001ce6c26c9dc1171b2d3 (diff)
downloadaur-77134c547ba5e7055fd3ef87dc2466a929466428.tar.gz
packaging update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD39
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23c2657e3ac1..462c086756db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ranger_devicons-git
pkgdesc = Ranger plugin that adds file glyphs/icon support to Ranger
- pkgver = r83.feb2d7a
+ pkgver = r87.5bb1c32
pkgrel = 1
url = https://github.com/alexanderjeurissen/ranger_devicons
install = ranger_devicons.install
@@ -8,6 +8,9 @@ pkgbase = ranger_devicons-git
license = GPL3
makedepends = git
depends = ranger
+ depends = nerd-fonts
+ provides = ranger_devicons
+ conflicts = ranger_devicons
source = ranger_devicons-git::git+https://github.com/alexanderjeurissen/ranger_devicons
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4f12ba976b09..941ab6ef86bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
-# Maintainer: wostarxi <wostarxi@outlook.com>
-_pkgname=ranger_devicons
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: wostarxi <wostarxi@outlook.com>
+
pkgname=ranger_devicons-git
-pkgver=r83.feb2d7a
+_pkg="${pkgname%-git}"
+pkgver=r87.5bb1c32
pkgrel=1
-pkgdesc="Ranger plugin that adds file glyphs/icon support to Ranger"
-arch=("any")
-url="https://github.com/alexanderjeurissen/ranger_devicons"
+pkgdesc='Ranger plugin that adds file glyphs/icon support to Ranger'
+arch=('any')
+url='https://github.com/alexanderjeurissen/ranger_devicons'
license=('GPL3')
-depends=("ranger")
+depends=('ranger' 'nerd-fonts')
makedepends=('git')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install="${_pkgname}.install"
-source=("${pkgname}::git+${url}")
+provides=("$_pkg")
+conflicts=("$_pkg")
+install="$_pkg.install"
+source=("$pkgname::git+$url")
md5sums=('SKIP')
+
pkgver() {
- cd "${srcdir}/${pkgname}"
- # Git, no tags available
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/${pkgname}"
- install -m 755 -D __init__.py "$pkgdir/usr/share/ranger/plugins/ranger_devicons/__init__.py"
- install -m 755 -D devicons.py "$pkgdir/usr/share/ranger/plugins/ranger_devicons/devicons.py"
+ cd "$pkgname"
+ install -Dv __init__.py devicons.py -t "$pkgdir/usr/share/ranger/plugins/$_pkg/"
}