summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 10:27:39 +0800
committerzxp198210052024-03-22 10:27:39 +0800
commit6e097a507270787ca45d2290a830775eccb417e6 (patch)
tree5215f438662f3aa3441bea3065a5038f55436f42
parent40eadc2a08d57669a1d533fbcf0dfedb89826d50 (diff)
downloadaur-6e097a507270787ca45d2290a830775eccb417e6.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--rao-pics.sh5
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 860d0829c301..f3063894061e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = rao-pics-bin
pkgdesc = RaoPics help you visit material on any devices, base on Eagle/Billfish/Pixcall and other photos material management apps.
pkgver = 0.7.16
- pkgrel = 5
+ pkgrel = 6
url = https://rao.pics/
arch = aarch64
arch = x86_64
license = AGPL-3.0-only
- depends = electron20
- depends = hicolor-icon-theme
+ depends = electron20-bin
depends = openssl-1.1
depends = nodejs
provides = rao-pics=0.7.16
conflicts = rao-pics
source = rao-pics.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = rao-pics-0.7.16-aarch64.deb::https://github.com/rao-pics/rao-pics/releases/download/v0.7.16/Rao.Pics-0.7.16-linux-arm64-openssl-1.1.x.deb
sha256sums_aarch64 = 6e2bd0fdf5133ecd11c66dc069c75955f7e37ae6cfb8fc06a37e0f32913c9d29
source_x86_64 = rao-pics-0.7.16-x86_64.deb::https://github.com/rao-pics/rao-pics/releases/download/v0.7.16/Rao.Pics-0.7.16-linux-amd64-openssl-1.1.x.deb
diff --git a/PKGBUILD b/PKGBUILD
index 36ef6cf6df38..b09b2a66cf05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _appname="Rao Pics"
_pkgname="@acmeelectron"
pkgver=0.7.16
_electronversion=20
-pkgrel=5
+pkgrel=6
pkgdesc="RaoPics help you visit material on any devices, base on Eagle/Billfish/Pixcall and other photos material management apps."
arch=(
'aarch64'
@@ -16,21 +16,21 @@ license=('AGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
- 'hicolor-icon-theme'
+ "electron${_electronversion}-bin"
'openssl-1.1'
'nodejs'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${_appname// /.}-${pkgver}-linux-arm64-openssl-1.1.x.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${_appname// /.}-${pkgver}-linux-amd64-openssl-1.1.x.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('6e2bd0fdf5133ecd11c66dc069c75955f7e37ae6cfb8fc06a37e0f32913c9d29')
sha256sums_x86_64=('7b53f1988cdf792b4f46c1f6e52fb28adccd0b95b47058a191f393feeb475c41')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_appname}/${_pkgname}\"|${pkgname%-bin}|g;s|${_pkgname}|${pkgname%-bin}|g" \
diff --git a/rao-pics.sh b/rao-pics.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/rao-pics.sh
+++ b/rao-pics.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file