summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:27:19 +0200
committerM0Rf302015-06-17 16:27:19 +0200
commit6385abae2f5b6beedebfbf62171f4d5f76492843 (patch)
tree3bd58d2f16e4f7c4abcd71a8c8dd8ac9a056f6d6
downloadaur-6385abae2f5b6beedebfbf62171f4d5f76492843.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--patch10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32ef57db67f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rapid-spring-git
+ pkgdesc = Commandline client for Spring rapid downloading system
+ pkgver = 233.df54975
+ pkgrel = 1
+ url = http://github.com/tvo/rapid/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-bitarray
+ depends = python2
+ depends = spring
+ depends = python-pip
+ depends = python2-cx_freeze
+ source = rapid::git://github.com/tvo/rapid.git
+ source = patch
+ md5sums = SKIP
+ md5sums = 278ddeedb23a852ae2fa9957fddde982
+
+pkgname = rapid-spring-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e0a89ab0ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Pimper : M0Rf30
+
+pkgname=rapid-spring-git
+pkgver=233.df54975
+pkgrel=1
+pkgdesc="Commandline client for Spring rapid downloading system"
+arch=('i686' 'x86_64')
+url="http://github.com/tvo/rapid/"
+license=('GPL')
+depends=('python2-bitarray' 'python2' 'spring' 'python-pip' 'python2-cx_freeze')
+source=("rapid::git://github.com/tvo/rapid.git"
+ 'patch')
+
+package() {
+ cd rapid
+ patch -Np0 -i ../patch
+ python2 setup.py install --root=$pkgdir
+
+}
+
+pkgver() {
+ cd rapid
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP'
+ '278ddeedb23a852ae2fa9957fddde982')
diff --git a/patch b/patch
new file mode 100644
index 000000000000..38d2d99fc867
--- /dev/null
+++ b/patch
@@ -0,0 +1,10 @@
+--- setup.py 2010-09-19 11:14:01.357000362 +0200
++++ ../../setup.py 2010-09-19 11:31:20.317000361 +0200
+@@ -11,7 +11,6 @@
+ url='http://pypi.python.org/pypi/rapid-spring/',
+ license='LICENSE.txt',
+ description='spring content downloading',
+- long_description=open('README.txt').read(),
+ # running `setup.py sdist' gives a warning about this, but still
+ # install_requires is the only thing that works with pip/easy_install...
+ install_requires=['bitarray'],