summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitlab CI Runner2021-04-28 16:11:39 +0000
committerGitlab CI Runner2021-04-28 16:11:39 +0000
commita0c5b2eb15f5eb2d75b06fb2c3304b70de053d2b (patch)
tree6f8b75c68360aed6698832f64be0ec140c55da74
parent2581184223792a3f71dd8f6f20c6ee3a3a5d594a (diff)
downloadaur-rapidcheck.tar.gz
Updated package to commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--rapidcheck.changelog35
3 files changed, 41 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6c51475cbba..00310230de01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rapidcheck
pkgdesc = QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible.
- pkgver = r1010.b78f892
+ pkgver = r1018.fc61611
pkgrel = 1
url = https://github.com/emil-e/rapidcheck
changelog = rapidcheck.changelog
@@ -12,8 +12,8 @@ pkgbase = rapidcheck
arch = aarch64
license = BSD
makedepends = cmake
- provides = rapidcheck=r1010.b78f892
- source = rapidcheck::https://github.com/emil-e/rapidcheck/archive/b78f89288c7e086d06e2a1e10b605d8375517a8a.tar.gz
+ provides = rapidcheck=r1018.fc61611
+ source = rapidcheck::https://github.com/emil-e/rapidcheck/archive/fc616114a95a3198514f8b4ec9e354865fd6ecfc.tar.gz
md5sums = SKIP
pkgname = rapidcheck
diff --git a/PKGBUILD b/PKGBUILD
index b916c0bc9509..936ceef4e2c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <bart at verhagenconsultancy dot be>
pkgname=('rapidcheck')
pkgbase='rapidcheck'
-pkgver=r1010.b78f892
+pkgver=r1018.fc61611
pkgrel=1
epoch=
pkgdesc="QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible."
@@ -13,18 +13,18 @@ depends=()
makedepends=(cmake)
checkdepends=()
optdepends=()
-provides=('rapidcheck=r1010.b78f892')
+provides=('rapidcheck=r1018.fc61611')
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=rapidcheck.changelog
-source=("rapidcheck::$url/archive/b78f89288c7e086d06e2a1e10b605d8375517a8a.tar.gz")
+source=("rapidcheck::$url/archive/fc616114a95a3198514f8b4ec9e354865fd6ecfc.tar.gz")
noextract=()
validpgpkeys=()
-_git_dir='rapidcheck-b78f89288c7e086d06e2a1e10b605d8375517a8a'
+_git_dir='rapidcheck-fc616114a95a3198514f8b4ec9e354865fd6ecfc'
_build_dir='build'
_build_targets=('all')
diff --git a/rapidcheck.changelog b/rapidcheck.changelog
index 639700f2aa36..4eaa3f481b3b 100644
--- a/rapidcheck.changelog
+++ b/rapidcheck.changelog
@@ -2,11 +2,12 @@ Changelog
=========
-r1010.b78f892
+r1018.fc61611
------------
Fix
~~~
+- Fix build errors on MSVC with /std:c++latest. [Masashi Fujita]
- Resurrect Clang fix. [Masashi Fujita]
5e66557a88ab747985913b2406c9157cfe377a0b is wrong :-(
@@ -17,6 +18,38 @@ Fix
Other
~~~~~
+- Merge pull request #273 from objectx/fix/msvc-cpp-20. [emil-e]
+
+ Fix build errors on MSVC with /std:c++latest
+- Merge pull request #272 from joelwilliamson/master. [emil-e]
+
+ Remove implicit capture of this
+- Remove implicit capture of this. [Joel Williamson]
+
+ GCC emits a deprecated warning when 'this' is implicitly captured by
+ value. Change the lambdas that were implicitly capturing to an explicit
+ capture.
+- Merge pull request #271 from
+ MicheleCicciottiWork/MicheleCicciottiWork-return_type. [emil-e]
+
+ Fix rc::compat::return_type definition warning
+- Fix rc::compat::return_type definition warning. [MicheleCicciottiWork]
+
+ Alias `rc::compat::return_type` to `std::result_of` for C++14 and earlier, instead of C++17 and earlier as it used to be.
+
+ The reason is that `std::result_of`, while still available in C++17, is deprecated and may result in warnings, for example warning STL4014 in Visual Studio 2017:
+
+ ```
+ c:\project\thirdparty\rapidcheck\include\rapidcheck\compat.hpp(10): error C4996: 'std::result_of<_Callable(_Args...)>': warning STL4014: std::result_of and std::result_of_t are deprecated in C++17. They are superseded by std::invoke_result and std::invoke_result_t. You can define _SILENCE_CXX17_RESULT_OF_DEPRECATION_WARNING or _SILENCE_ALL_CXX17_DEPRECATION_WARNINGS to acknowledge that you have received this warning.
+ ```
+- Merge pull request #269 from mkloczko/compat20. [emil-e]
+
+ Added rc::compat::return_type for both std::result_of and std::invoke_result
+- Support for C++11 and C++20 (std::result_of vs std::invoke_result)
+ [Mateusz Kłoczko]
+
+ The compatibilty is done by adding using clause named
+ ```rc::compat::return_type``` in ```rapidcheck/Compat.hpp```.
- Merge pull request #268 from tsmanner/invert_use_rtti_flag. [emil-e]
Inverted logic of rtti enablement.