summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTolga HOŞGÖR2015-06-09 03:35:50 +0300
committerTolga HOŞGÖR2015-06-09 03:35:50 +0300
commitb35a9e44bb8a437411077a7c7c7582f7335772b0 (patch)
tree062cf0eaf5294cc99f8a4ee2dcac9212d0cd5dfe
downloadaur-b35a9e44bb8a437411077a7c7c7582f7335772b0.tar.gz
initial commit
Signed-off-by: Tolga HOŞGÖR <fasdfasdas@gmail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0fcb1bab077
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rapidjson-git
+ pkgdesc = Rapidjson is an attempt to create the fastest JSON parser and generator.
+ pkgver = r828.dd28719
+ pkgrel = 2
+ url = https://github.com/miloyip/rapidjson
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = rapidjson
+ conflicts = rapidjson
+ source = git+https://github.com/miloyip/rapidjson.git
+ md5sums = SKIP
+
+pkgname = rapidjson-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02995096ad10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tolga HOŞGÖR <fasdfasdas@gmail.com>
+
+pkgname=rapidjson-git
+pkgver=r828.dd28719
+pkgrel=2
+pkgdesc="Rapidjson is an attempt to create the fastest JSON parser and generator."
+
+arch=('any')
+url="https://github.com/miloyip/rapidjson"
+license=('GPL')
+conflicts=('rapidjson')
+provides=('rapidjson')
+makedepends=('git')
+source=('git+https://github.com/miloyip/rapidjson.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/rapidjson"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ true # header-only library
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/include"
+ cp -r "$srcdir/rapidjson/include/rapidjson" "$pkgdir/usr/include"
+ find "$pkgdir/usr/include/rapidjson/" -type d -exec chmod 755 {} \;
+ find "$pkgdir/usr/include/rapidjson/" -type f -exec chmod 644 {} \;
+}