summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2020-11-14 17:50:25 -0700
committernot_anonymous2020-11-14 17:50:25 -0700
commitd1b31b4023e95e922a1ada55c6284395cf71209a (patch)
tree4d2fc1283cd171534d9ccedc1c81b779a8bf6bf7
parentd625dec53633277e5910f34928a06260cdff8122 (diff)
downloadaur-d1b31b4023e95e922a1ada55c6284395cf71209a.tar.gz
Updated
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD83
-rw-r--r--rapidsvn-add-svncpp.dox.diff190
-rw-r--r--rapidsvn-link-libs.diff32
-rw-r--r--rapidsvn-locale-build.diff24
5 files changed, 308 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c94e4a1dac02..7d00ef8dbdb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = rapidsvn
pkgdesc = A cross-platform GUI front-end for the Subversion revision system written in C++ using the wxWidgets framework.
pkgver = 0.12.1
- pkgrel = 12
+ pkgrel = 13
url = http://rapidsvn.tigris.org/
arch = x86_64
license = GPL
makedepends = python2
+ makedepends = doxygen
depends = subversion
depends = wxgtk3
source = http://www.rapidsvn.org/download/release/0.12.1/rapidsvn-0.12.1.tar.gz
source = rapidsvn.desktop
source = rapidsvn-wx3.0.patch
source = rapidsvn-subversion1.9.patch
+ source = rapidsvn-add-svncpp.dox.diff
+ source = rapidsvn-locale-build.diff
+ source = rapidsvn-link-libs.diff
md5sums = 8de3ca6da3ef6a27d59f959d1bbcd96b
md5sums = 349e6d9729f88868902611bb1172f134
md5sums = 44cdc7e987496e9e331f3dd5b5a871d4
md5sums = 0ffd1fd1fed7ff53578afe92730c80bc
+ md5sums = e41f470f97fd721600030cebcc17bb3b
+ md5sums = 9fc75740d9b067448500be140a5a30cf
+ md5sums = 5ed33e98f5c87e92362a24acb8d20671
pkgname = rapidsvn
diff --git a/PKGBUILD b/PKGBUILD
index c34757229ece..4b5f604af1d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,83 @@
-# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Maintainer: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# PREVIOUS Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# PREVIOUS Maintainer: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor: AqD <aquila.deus@gmail.com>
# Contributor: TheMadsen <arch@themadsens.dk>
pkgname=rapidsvn
pkgver=0.12.1
-pkgrel=12
+pkgrel=13
pkgdesc="A cross-platform GUI front-end for the Subversion revision system written in C++ using the wxWidgets framework."
url='http://rapidsvn.tigris.org/'
arch=('x86_64')
license=('GPL')
depends=('subversion' 'wxgtk3')
-makedepends=('python2')
+makedepends=('python2' 'doxygen')
source=(http://www.rapidsvn.org/download/release/$pkgver/rapidsvn-$pkgver.tar.gz
- $pkgname.desktop rapidsvn-wx3.0.patch rapidsvn-subversion1.9.patch)
+ $pkgname.desktop
+ rapidsvn-wx3.0.patch
+ rapidsvn-subversion1.9.patch
+ rapidsvn-add-svncpp.dox.diff
+ rapidsvn-locale-build.diff
+ rapidsvn-link-libs.diff)
md5sums=('8de3ca6da3ef6a27d59f959d1bbcd96b'
'349e6d9729f88868902611bb1172f134'
'44cdc7e987496e9e331f3dd5b5a871d4'
- '0ffd1fd1fed7ff53578afe92730c80bc')
+ '0ffd1fd1fed7ff53578afe92730c80bc'
+ 'e41f470f97fd721600030cebcc17bb3b'
+ '9fc75740d9b067448500be140a5a30cf'
+ '5ed33e98f5c87e92362a24acb8d20671')
prepare() {
- cd $pkgname-$pkgver
-# Fix build with WxGTK 3 (Debian)
- patch -p1 -i ../rapidsvn-wx3.0.patch
-# Fix assertion at startup
- sed -e '/SetMaxLength(0)/d' -i src/rapidsvn_frame.cpp -i src/report_dlg.cpp
-# Fix build with subversion 1.9 (Debian)
- patch -p1 -i ../rapidsvn-subversion1.9.patch
+ cd $pkgname-$pkgver
+
+ # Fix assertion at startup
+ sed -e '/SetMaxLength(0)/d' -i src/rapidsvn_frame.cpp \
+ -i src/report_dlg.cpp
+
+ # Fix build with WxGTK 3 (Debian)
+ patch -p1 -i ../rapidsvn-wx3.0.patch
+
+ # Fix build with subversion 1.9 (Debian)
+ patch -p1 -i ../rapidsvn-subversion1.9.patch
+
+ # Fix build adding missing svncpp.dox (Debian)
+ patch -p1 -i ../rapidsvn-add-svncpp.dox.diff
+
+ # Fix build v/v wrong conditional (Debian)
+ patch -p1 -i ../rapidsvn-locale-build.diff
+
+ # Fix build v/v linking libsvncpp w/ dep/ libs (Debian)
+ patch -p1 -i ../rapidsvn-link-libs.diff
}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
+
+ autoreconf -vi
+
+ export CPPFLAGS+=' -DNDEBUG' # https://bugs.archlinux.org/task/52696
- autoreconf -vi
+ sed -i 's#src/tests/svncpp/Makefile##' configure
+ [ "$NOEXTRACT" == 1 ] || ./configure --prefix=/usr \
+ --with-apu-config="`which apu-1-config`" \
+ --with-apr-config="`which apr-1-config`" \
+ --with-wx-config=/usr/bin/wx-config-gtk3
- export CPPFLAGS+=' -DNDEBUG' # https://bugs.archlinux.org/task/52696
- sed -i 's#src/tests/svncpp/Makefile##' configure
- [ "$NOEXTRACT" == 1 ] || ./configure --prefix=/usr \
- --with-apu-config="`which apu-1-config`" \
- --with-apr-config="`which apr-1-config`" \
- --with-wx-config=/usr/bin/wx-config-gtk3
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2|' tools/*.py
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|' tools/*.py
- sed -i 's|python|python2|' src/locale/Makefile
+ sed -i 's|python|python2|' src/locale/Makefile
- make -k
+ make -k
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
- install -Dm644 src/res/bitmaps/rapidsvn_32x32.xpm "$pkgdir"/usr/share/pixmaps/rapidsvn_32x32.xpm
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 src/res/bitmaps/rapidsvn_32x32.xpm \
+ "$pkgdir"/usr/share/pixmaps/rapidsvn_32x32.xpm
+ install -Dm644 ../$pkgname.desktop \
+ "$pkgdir"/usr/share/applications/$pkgname.desktop
}
diff --git a/rapidsvn-add-svncpp.dox.diff b/rapidsvn-add-svncpp.dox.diff
new file mode 100644
index 000000000000..4efc33c4d65e
--- /dev/null
+++ b/rapidsvn-add-svncpp.dox.diff
@@ -0,0 +1,190 @@
+Description: Add missing upstream file doc/svncpp/svncpp.dox to generate documentation.
+Author: Mònica Ramírez Arceda <monica@debian.org>
+Last-Update: 2013-07-04
+
+--- /dev/null
++++ b/doc/svncpp/svncpp.dox
+@@ -0,0 +1,183 @@
++# Doxyfile for SvnCpp
++# To build this documentation download Doxygen http://www.doxygen.org/
++
++#---------------------------------------------------------------------------
++# General configuration options
++#---------------------------------------------------------------------------
++PROJECT_NAME = SvnCpp
++PROJECT_NUMBER =
++OUTPUT_DIRECTORY = .
++OUTPUT_LANGUAGE = English
++EXTRACT_ALL = YES
++EXTRACT_PRIVATE = NO
++EXTRACT_STATIC = NO
++EXTRACT_LOCAL_CLASSES = YES
++HIDE_UNDOC_MEMBERS = NO
++HIDE_UNDOC_CLASSES = NO
++BRIEF_MEMBER_DESC = YES
++REPEAT_BRIEF = YES
++ALWAYS_DETAILED_SEC = NO
++INLINE_INHERITED_MEMB = NO
++FULL_PATH_NAMES = NO
++STRIP_FROM_PATH =
++INTERNAL_DOCS = NO
++STRIP_CODE_COMMENTS = YES
++CASE_SENSE_NAMES = YES
++SHORT_NAMES = NO
++HIDE_SCOPE_NAMES = NO
++VERBATIM_HEADERS = YES
++SHOW_INCLUDE_FILES = YES
++JAVADOC_AUTOBRIEF = NO
++MULTILINE_CPP_IS_BRIEF = NO
++DETAILS_AT_TOP = NO
++INHERIT_DOCS = YES
++INLINE_INFO = YES
++SORT_MEMBER_DOCS = YES
++DISTRIBUTE_GROUP_DOC = NO
++TAB_SIZE = 8
++GENERATE_TODOLIST = YES
++GENERATE_TESTLIST = YES
++GENERATE_BUGLIST = YES
++ALIASES =
++ENABLED_SECTIONS =
++MAX_INITIALIZER_LINES = 30
++OPTIMIZE_OUTPUT_FOR_C = YES
++OPTIMIZE_OUTPUT_JAVA = NO
++SHOW_USED_FILES = YES
++#---------------------------------------------------------------------------
++# configuration options related to warning and progress messages
++#---------------------------------------------------------------------------
++QUIET = NO
++WARNINGS = YES
++WARN_IF_UNDOCUMENTED = NO
++WARN_FORMAT = "$file:$line: $text"
++WARN_LOGFILE =
++#---------------------------------------------------------------------------
++# configuration options related to the input files
++#---------------------------------------------------------------------------
++INPUT = ../../include/svncpp
++FILE_PATTERNS = *.hpp
++RECURSIVE = NO
++EXCLUDE =
++EXCLUDE_SYMLINKS = NO
++EXCLUDE_PATTERNS =
++EXAMPLE_PATH =
++EXAMPLE_PATTERNS =
++EXAMPLE_RECURSIVE = NO
++IMAGE_PATH =
++INPUT_FILTER =
++FILTER_SOURCE_FILES = NO
++#---------------------------------------------------------------------------
++# configuration options related to source browsing
++#---------------------------------------------------------------------------
++SOURCE_BROWSER = NO
++INLINE_SOURCES = NO
++REFERENCED_BY_RELATION = YES
++REFERENCES_RELATION = YES
++#---------------------------------------------------------------------------
++# configuration options related to the alphabetical class index
++#---------------------------------------------------------------------------
++ALPHABETICAL_INDEX = NO
++COLS_IN_ALPHA_INDEX = 5
++IGNORE_PREFIX =
++#---------------------------------------------------------------------------
++# configuration options related to the HTML output
++#---------------------------------------------------------------------------
++GENERATE_HTML = YES
++HTML_OUTPUT = html
++HTML_FILE_EXTENSION = .html
++HTML_HEADER =
++HTML_FOOTER =
++HTML_STYLESHEET =
++HTML_ALIGN_MEMBERS = YES
++GENERATE_HTMLHELP = YES
++CHM_FILE = svncpp.chm
++HHC_LOCATION =
++GENERATE_CHI = NO
++BINARY_TOC = NO
++TOC_EXPAND = NO
++DISABLE_INDEX = NO
++ENUM_VALUES_PER_LINE = 4
++GENERATE_TREEVIEW = NO
++TREEVIEW_WIDTH = 250
++#---------------------------------------------------------------------------
++# configuration options related to the LaTeX output
++#---------------------------------------------------------------------------
++GENERATE_LATEX = NO
++LATEX_OUTPUT = latex
++LATEX_CMD_NAME = latex
++MAKEINDEX_CMD_NAME = makeindex
++COMPACT_LATEX = NO
++PAPER_TYPE = a4wide
++EXTRA_PACKAGES =
++LATEX_HEADER =
++PDF_HYPERLINKS = NO
++USE_PDFLATEX = NO
++LATEX_BATCHMODE = NO
++#---------------------------------------------------------------------------
++# configuration options related to the RTF output
++#---------------------------------------------------------------------------
++GENERATE_RTF = NO
++RTF_OUTPUT = rtf
++COMPACT_RTF = NO
++RTF_HYPERLINKS = NO
++RTF_STYLESHEET_FILE =
++RTF_EXTENSIONS_FILE =
++#---------------------------------------------------------------------------
++# configuration options related to the man page output
++#---------------------------------------------------------------------------
++GENERATE_MAN = NO
++MAN_OUTPUT = man
++MAN_EXTENSION = .3
++MAN_LINKS = NO
++#---------------------------------------------------------------------------
++# configuration options related to the XML output
++#---------------------------------------------------------------------------
++GENERATE_XML = NO
++#---------------------------------------------------------------------------
++# configuration options for the AutoGen Definitions output
++#---------------------------------------------------------------------------
++GENERATE_AUTOGEN_DEF = NO
++#---------------------------------------------------------------------------
++# Configuration options related to the preprocessor
++#---------------------------------------------------------------------------
++ENABLE_PREPROCESSING = YES
++MACRO_EXPANSION = NO
++EXPAND_ONLY_PREDEF = NO
++SEARCH_INCLUDES = YES
++INCLUDE_PATH =
++INCLUDE_FILE_PATTERNS =
++PREDEFINED =
++EXPAND_AS_DEFINED =
++SKIP_FUNCTION_MACROS = YES
++#---------------------------------------------------------------------------
++# Configuration::addtions related to external references
++#---------------------------------------------------------------------------
++TAGFILES =
++GENERATE_TAGFILE =
++ALLEXTERNALS = NO
++EXTERNAL_GROUPS = YES
++PERL_PATH = /usr/bin/perl
++#---------------------------------------------------------------------------
++# Configuration options related to the dot tool
++#---------------------------------------------------------------------------
++CLASS_DIAGRAMS = YES
++HIDE_UNDOC_RELATIONS = YES
++HAVE_DOT = YES
++CLASS_GRAPH = NO
++COLLABORATION_GRAPH = NO
++TEMPLATE_RELATIONS = YES
++INCLUDE_GRAPH = NO
++INCLUDED_BY_GRAPH = YES
++GRAPHICAL_HIERARCHY = YES
++DOT_IMAGE_FORMAT = png
++DOT_PATH =
++DOTFILE_DIRS =
++MAX_DOT_GRAPH_WIDTH = 1024
++MAX_DOT_GRAPH_HEIGHT = 1024
++GENERATE_LEGEND = NO
++DOT_CLEANUP = YES
++#---------------------------------------------------------------------------
++# Configuration::addtions related to the search engine
++#---------------------------------------------------------------------------
++SEARCHENGINE = NO
diff --git a/rapidsvn-link-libs.diff b/rapidsvn-link-libs.diff
new file mode 100644
index 000000000000..7fe245fb86ca
--- /dev/null
+++ b/rapidsvn-link-libs.diff
@@ -0,0 +1,32 @@
+Description: Link libsvncpp with dependent libraries.
+--- a/src/svncpp/Makefile.in
++++ b/src/svncpp/Makefile.in
+@@ -75,7 +75,9 @@
+ }
+ am__installdirs = "$(DESTDIR)$(libdir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libsvncpp_la_LIBADD =
++am__DEPENDENCIES_1 =
++libsvncpp_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
++ $(am__DEPENDENCIES_1)
+ am_libsvncpp_la_OBJECTS = apr.lo client.lo client_annotate.lo \
+ client_cat.lo client_diff.lo client_ls.lo client_modify.lo \
+ client_property.lo client_status.lo context.lo datetime.lo \
+@@ -243,6 +245,7 @@
+ noinst_HEADERS = ${wildcard *.hpp}
+ lib_LTLIBRARIES = libsvncpp.la
+ libsvncpp_la_LDFLAGS = -version-info 3:0:0
++libsvncpp_la_LIBADD = $(SVN_LIBS) $(APR_LIBS)
+ libsvncpp_la_SOURCES = \
+ apr.cpp \
+ client.cpp \
+--- a/src/svncpp/Makefile.am
++++ b/src/svncpp/Makefile.am
+@@ -3,6 +3,7 @@
+ lib_LTLIBRARIES=libsvncpp.la
+
+ libsvncpp_la_LDFLAGS=-version-info 3:0:0
++libsvncpp_la_LIBADD=$(SVN_LIBS) $(APR_LIBS)
+ libsvncpp_la_SOURCES= \
+ apr.cpp \
+ client.cpp \
diff --git a/rapidsvn-locale-build.diff b/rapidsvn-locale-build.diff
new file mode 100644
index 000000000000..ed452d578986
--- /dev/null
+++ b/rapidsvn-locale-build.diff
@@ -0,0 +1,24 @@
+Description: Fix wrong conditional.
+--- a/src/locale/Makefile.in
++++ b/src/locale/Makefile.in
+@@ -405,8 +405,7 @@
+ distclean: clean
+ clean:
+ for i in $(RAPIDSVN_LANGUAGES) ; do \
+- test -f $(srcdir)/$$i/rapidsvn.mo && rm $(srcdir)/$$i/rapidsvn.mo ; \
+- fi ; \
++ test -f $(srcdir)/$$i/rapidsvn.mo && rm $(srcdir)/$$i/rapidsvn.mo || true; \
+ done
+ .PHONY: all-mo
+
+--- a/src/locale/Makefile.am
++++ b/src/locale/Makefile.am
+@@ -38,7 +38,6 @@
+ distclean: clean
+ clean:
+ for i in $(RAPIDSVN_LANGUAGES) ; do \
+- test -f $(srcdir)/$$i/rapidsvn.mo && rm $(srcdir)/$$i/rapidsvn.mo ; \
+- fi ; \
++ test -f $(srcdir)/$$i/rapidsvn.mo && rm $(srcdir)/$$i/rapidsvn.mo || true; \
+ done
+ .PHONY: all-mo