summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2023-05-14 13:45:28 +0000
committerXiretza2023-05-14 13:45:28 +0000
commit7e29a55bf3ebdc6ae04d79e81604169b58f9d8b1 (patch)
tree6e5a8f093a6ab25926bee5ab3744d55eaed59739
parent0757c4a90ae95df2cf66e779f8587aed35583920 (diff)
downloadaur-7e29a55bf3ebdc6ae04d79e81604169b58f9d8b1.tar.gz
Update for added dependencies, use PEP 517 workflow
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Remove-bogus-ninja-wheel-dependency.patch23
-rw-r--r--PKGBUILD29
3 files changed, 60 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 924645222c3d..04e2ef006c26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rapidyaml-git
pkgdesc = A library to parse and emit YAML, and do it fast.
- pkgver = 0.2.3.r21.gefc8b0e
+ pkgver = 0.5.0.r14.g6a5a07f
pkgrel = 1
url = https://github.com/biojppm/rapidyaml
arch = x86_64
@@ -8,24 +8,35 @@ pkgbase = rapidyaml-git
checkdepends = python-pytest
makedepends = git
makedepends = cmake
+ makedepends = ninja
makedepends = swig
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-git
makedepends = python-setuptools-scm
- makedepends = python-cmake-build-extension
+ makedepends = python-cmake-build-extension-git
source = git+https://github.com/biojppm/rapidyaml.git
source = git+https://github.com/biojppm/c4core.git
source = git+https://github.com/biojppm/cmake.git
+ source = git+https://github.com/biojppm/debugbreak
+ source = git+https://github.com/fastfloat/fast_float
+ source = 0001-Remove-bogus-ninja-wheel-dependency.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c12e283c0c0e970f7150068cf44f5106b4459f745f0b57513acd7bbfcbec897f
pkgname = rapidyaml-git
- provides = rapidyaml=0.2.3.r21.gefc8b0e
+ provides = rapidyaml=0.5.0.r14.g6a5a07f
provides = c4core
conflicts = rapidyaml
conflicts = c4core
pkgname = python-rapidyaml-git
depends = python
- provides = python-rapidyaml=0.2.3.r21.gefc8b0e
+ depends = python-deprecation
+ provides = python-rapidyaml=0.5.0.r14.g6a5a07f
conflicts = python-rapidyaml
diff --git a/0001-Remove-bogus-ninja-wheel-dependency.patch b/0001-Remove-bogus-ninja-wheel-dependency.patch
new file mode 100644
index 000000000000..6a3e866e0604
--- /dev/null
+++ b/0001-Remove-bogus-ninja-wheel-dependency.patch
@@ -0,0 +1,23 @@
+From 0c30de4681724c5531c24b1bfa44e055caa95e63 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sat, 13 May 2023 20:50:54 +0000
+Subject: [PATCH] Remove bogus ninja wheel dependency
+
+ninja is installed as a system package, not as a python wheel.
+---
+ pyproject.toml | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 2a5bc90..8bc6953 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -4,5 +4,4 @@ requires = [
+ "setuptools_scm[toml]>=3.4",
+ "setuptools-git",
+ "wheel",
+- "ninja",
+ "cmake_build_extension"]
+--
+2.40.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 9aeb85c76f72..29a27f4bb2ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,31 @@
_pkgname=rapidyaml
pkgbase=$_pkgname-git
pkgname=($pkgbase python-$pkgbase)
-pkgver=0.2.3.r21.gefc8b0e
+pkgver=0.5.0.r14.g6a5a07f
pkgrel=1
pkgdesc="A library to parse and emit YAML, and do it fast."
url="https://github.com/biojppm/rapidyaml"
arch=(x86_64)
license=('MIT')
-makedepends=('git' 'cmake' 'swig' 'python-setuptools' 'python-setuptools-scm' 'python-cmake-build-extension')
+makedepends=('git' 'cmake' 'ninja' 'swig' 'python-build' 'python-installer' 'python-wheel'
+ 'python-setuptools-git' 'python-setuptools-scm'
+ # note: contains additional patches for broken upstream not present in community package
+ 'python-cmake-build-extension-git')
checkdepends=('python-pytest')
source=(
"git+https://github.com/biojppm/rapidyaml.git"
"git+https://github.com/biojppm/c4core.git"
"git+https://github.com/biojppm/cmake.git"
+ "git+https://github.com/biojppm/debugbreak"
+ "git+https://github.com/fastfloat/fast_float"
+ "0001-Remove-bogus-ninja-wheel-dependency.patch"
)
sha256sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'c12e283c0c0e970f7150068cf44f5106b4459f745f0b57513acd7bbfcbec897f')
pkgver() {
cd "$_pkgname"
@@ -29,17 +38,21 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ patch -p1 < "$srcdir/0001-Remove-bogus-ninja-wheel-dependency.patch"
+
sed -i -e 's/-git//' setup.py
git submodule init
git config submodule.extern/c4core.url "$srcdir/c4core"
- git submodule update
+ git -c protocol.allow=never -c protocol.file.allow=always submodule update
cd ext/c4core
git submodule init
git config submodule.cmake.url "$srcdir/cmake"
- git submodule update
+ git config submodule.extern/debugbreak.url "$srcdir/debugbreak"
+ git config submodule.src/c4/ext/fast_float.url "$srcdir/fast_float"
+ git -c protocol.allow=never -c protocol.file.allow=always submodule update
}
build() {
@@ -51,7 +64,7 @@ build() {
cd "$_pkgname"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -72,13 +85,13 @@ package_rapidyaml-git() {
}
package_python-rapidyaml-git() {
- depends=('python')
+ depends=('python' 'python-deprecation')
provides=("${pkgname%%-git}=$pkgver")
conflicts=("${pkgname%%-git}")
cd "$_pkgname"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}