summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButter Cat2024-02-28 21:15:48 -0500
committerButter Cat2024-02-28 21:15:48 -0500
commita099ed341e2aca5b55b62c7d94369e692e0d3df8 (patch)
tree74daf59c920e29babe9db327703fad8aff5eea01
parentd098537222add717623046686dbc157357d540a6 (diff)
downloadaur-a099ed341e2aca5b55b62c7d94369e692e0d3df8.tar.gz
Initial upload. Not sure what happened to the original package.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD45
2 files changed, 23 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 543adffd66fb..9e3e763aaaac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,10 @@ pkgbase = rapl-read-ryzen-git
arch = any
license = GPL
makedepends = git
- source = rapl-read-ryzen-git::git+https://github.com/djselbeck/rapl-read-ryzen
- md5sums = SKIP
+ makedepends = gcc
+ provides = rapl-read-ryzen
+ conflicts = rapl-read-ryzen
+ source = rapl-read-ryzen::git+https://github.com/djselbeck/rapl-read-ryzen
+ sha256sums = SKIP
pkgname = rapl-read-ryzen-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 862b89235241..0f9863086410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
-# Maintainer: Robin Appelman <robin@icewind.nl>
-pkgname=rapl-read-ryzen-git
+# Maintainer: Butter Cat <ButteredCats@protonmail.com>
+# Contributor: Robin Appelman <robin@icewind.nl>
+
+_pkgname="rapl-read-ryzen"
+pkgname="${_pkgname}-git"
pkgver=r5.30636f0
-pkgver() {
- cd "$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
pkgrel=1
pkgdesc="Quick & dirty hack to read AMD Ryzen rapl counters"
arch=('any')
url="https://github.com/djselbeck/rapl-read-ryzen"
license=('GPL')
-groups=()
-depends=()
-makedepends=("git")
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("$pkgname::git+https://github.com/djselbeck/rapl-read-ryzen")
-noextract=()
+makedepends=('git' 'gcc')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
build() {
- cd $pkgname/
+ cd "${_pkgname}"
gcc -o rapl ryzen.c -lm
}
package() {
- cd $pkgname/
- install -D -m755 "rapl" "$pkgdir/usr/bin/rapl"
+ cd "${_pkgname}"
+ install -D -m755 "rapl" "${pkgdir}/usr/bin/rapl"
}
-
-md5sums=('SKIP')