summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-09 00:36:25 -0500
committerLuis Martinez2022-05-09 00:36:25 -0500
commita080bd8ad0383eb82a8a50283aebb763d9042535 (patch)
tree749716f4938d19a292135aaebbd0b3b76b966fee
parent4317e98a2d76dc7cfa66b5e7bde919f4a87c0303 (diff)
downloadaur-raptor1.tar.gz
package cleanup
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
2 files changed, 39 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ffa65ac39a3..7beaa21e76cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = raptor1
pkgdesc = C library that parses RDF/XML/N-Triples into RDF triples - old V1 api for compatibility
pkgver = 1.4.21
- pkgrel = 5
- url = http://librdf.org/raptor
- arch = i686
+ pkgrel = 6
+ url = https://librdf.org/raptor
arch = x86_64
license = LGPL
- depends = curl
- depends = libxslt
- options = !libtool
+ depends = libcurl.so
+ depends = libxslt.so
+ provides = libraptor.so=1-64
+ provides = raptor=1.4.21
options = !docs
- source = http://librdf.org/dist/source/raptor-1.4.21.tar.gz
+ source = raptor1-1.4.21.tar.gz::https://librdf.org/dist/source/raptor-1.4.21.tar.gz
+ source = raptor1-1.4.21.tar.gz.asc::https://librdf.org/dist/source/raptor-1.4.21.tar.gz.asc
source = curl.patch
- md5sums = 992061488af7a9e2d933df6b694bb876
- md5sums = 8fe28761645d6a6607b25c94f9ada964
+ validpgpkeys = F879F0DEDA780198DD08DC6443EC92504F71955A
+ sha256sums = db3172d6f3c432623ed87d7d609161973d2f7098e3d2233d0702fbcc22cfd8ca
+ sha256sums = SKIP
+ sha256sums = b241d4ef063ba24dc69369eb36f1b16c38dd7710c88ccd10bbcb4f2a3eff1245
pkgname = raptor1
-
diff --git a/PKGBUILD b/PKGBUILD
index a212b5959e3a..50fba40a4fca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,46 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Andreas Radke <andyrtr at archlinux.org>
# Contributor: eric <eric@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
pkgname=raptor1
-pkgrel=5
pkgver=1.4.21
+pkgrel=6
pkgdesc='C library that parses RDF/XML/N-Triples into RDF triples - old V1 api for compatibility'
-arch=('i686' 'x86_64')
-url="http://librdf.org/raptor"
-depends=('curl' 'libxslt')
+arch=('x86_64')
+url="https://librdf.org/raptor"
+depends=('libcurl.so' 'libxslt.so')
license=('LGPL')
-options=('!libtool' '!docs')
-source=("http://librdf.org/dist/source/raptor-$pkgver.tar.gz"
+provides=("libraptor.so=1-64" "raptor=$pkgver")
+options=('!docs')
+source=("$pkgname-$pkgver.tar.gz::https://librdf.org/dist/source/raptor-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://librdf.org/dist/source/raptor-$pkgver.tar.gz.asc"
'curl.patch')
-md5sums=('992061488af7a9e2d933df6b694bb876'
- '8fe28761645d6a6607b25c94f9ada964')
+sha256sums=('db3172d6f3c432623ed87d7d609161973d2f7098e3d2233d0702fbcc22cfd8ca'
+ 'SKIP'
+ 'b241d4ef063ba24dc69369eb36f1b16c38dd7710c88ccd10bbcb4f2a3eff1245')
+validpgpkeys=('F879F0DEDA780198DD08DC6443EC92504F71955A') ## Dave Beckett
prepare() {
- cd "${srcdir}"/raptor-${pkgver}
-
- patch -p1 -i "${srcdir}"/curl.patch
+ patch -p1 -d "raptor-$pkgver" < curl.patch
}
build() {
- cd "${srcdir}"/raptor-${pkgver}
+ cd "raptor-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --program-suffix=1 \
+ --disable-static
+ make
+}
- ./configure --prefix=/usr \
- --disable-static
- make
+check() {
+ cd "raptor-$pkgver"
+ make check
}
package() {
- cd "${srcdir}/raptor-${pkgver}"
- make prefix="${pkgdir}"/usr install
-
- install -Dm755 "${pkgdir}"/usr/bin/rapper "${pkgdir}"/usr/bin/rapperV1
- rm -f "${pkgdir}"/usr/bin/rapper
- install -Dm644 "${pkgdir}"/usr/share/man/man1/rapper.1 "${pkgdir}"/usr/share/man/man1/rapperV1.1
- rm -f "${pkgdir}"/usr/share/man/man1/rapper.1
+ cd "raptor-$pkgver"
+ make install DESTDIR="$pkgdir/"
}
-