summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:37:55 +0200
committerSanskritFritz2015-06-14 00:37:55 +0200
commit353f82dbe0512cee6e4912ba8136db96ba3afe7d (patch)
tree89aaae9acc7a598087ae8dd7f5bd9ac4a2c14e73
downloadaur-353f82dbe0512cee6e4912ba8136db96ba3afe7d.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--file-type-detection.patch15
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3145a89cf061
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rarcrack
+ pkgdesc = Use brute force algorithm to find the correct password for rar, 7z, zip archives.
+ pkgver = 0.2
+ pkgrel = 4
+ url = http://rarcrack.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxml2
+ optdepends = unrar: to crack rar archives
+ optdepends = unrar-free: to crack rar archives
+ optdepends = p7zip: to crack 7z archives
+ optdepends = unzip: to crack zip archives
+ source = http://sourceforge.net/projects/rarcrack/files/rarcrack-0.2/%5BUnnamed%20release%5D/rarcrack-0.2.tar.bz2
+ source = file-type-detection.patch
+ md5sums = 62d0cf77c6c4edc7204305649f8b7362
+ md5sums = 5866a692fe1ea4bcd8df85fd914c51aa
+
+pkgname = rarcrack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c186b811f26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: jll <paci79@free.fr>
+# Contributor: Giancarlo Bianchi <giancarlobianchi76 -at- gmail -dot- com>
+# Contributor: optiseth (AUR)
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=rarcrack
+pkgver=0.2
+pkgrel=4
+pkgdesc="Use brute force algorithm to find the correct password for rar, 7z, zip archives."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://rarcrack.sourceforge.net/"
+depends=('libxml2')
+optdepends=('unrar: to crack rar archives'
+ 'unrar-free: to crack rar archives'
+ 'p7zip: to crack 7z archives'
+ 'unzip: to crack zip archives')
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver/%5BUnnamed%20release%5D/$pkgname-$pkgver.tar.bz2"
+ "file-type-detection.patch")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # https://github.com/optiseth/rarcrack-fix Thank you optiseth:
+ patch < "$srcdir/file-type-detection.patch"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D -m0755 rarcrack "$pkgdir/usr/bin/rarcrack"
+ install -d -m0755 "$pkgdir/usr/share/doc/$pkgname"
+ install -m0644 -t "$pkgdir/usr/share/doc/$pkgname" CHANGELOG LICENSE README README.html RELEASE_NOTES
+}
+
+md5sums=('62d0cf77c6c4edc7204305649f8b7362'
+ '5866a692fe1ea4bcd8df85fd914c51aa')
+
diff --git a/file-type-detection.patch b/file-type-detection.patch
new file mode 100644
index 000000000000..abff0c94a00f
--- /dev/null
+++ b/file-type-detection.patch
@@ -0,0 +1,15 @@
+--- rarcrack.h 2007-10-18 09:18:12.000000000 -0600
++++ rarcrack.h.fix 2013-05-30 14:14:55.572552968 -0600
+@@ -31,10 +31,10 @@
+
+ char default_ABC[] = "0123456789abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ";
+
+-const char CMD_DETECT[] = "file -i -b %s"; //this command return what is the file mime type
++const char CMD_DETECT[] = "file -b --mime-type %s"; //this command return what is the file mime type
+
+ const char* TYPE[] = {"rar", "7z", "zip", ""}; //the last "" signing this is end of the list
+-const char* MIME[] = {"application/x-rar", "application/octet-stream", "application/x-zip", ""};
++const char* MIME[] = {"application/x-rar", "application/x-7z-compressed", "application/zip", ""};
+ const char* CMD[] = {"unrar t -y -p%s %s 2>&1", "7z t -y -p%s %s 2>&1", "unzip -P%s -t %s 2>&1", ""};
+
+ #define PWD_LEN 100