summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpfm2019-11-14 22:27:51 +0100
committerpfm2019-11-14 22:27:51 +0100
commit3757fbcf785c2945ac421edbc944a76dfb0efebb (patch)
treedbbb999fe240b7cb7fcb62811c44522f0cc01100
parentcfc2824d924cc2a0a5828cf050d2e5725207e544 (diff)
downloadaur-3757fbcf785c2945ac421edbc944a76dfb0efebb.tar.gz
Move patching to the prepare function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdeb31c8b61c..4de00d63a774 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rarcrack
pkgdesc = Use brute force algorithm to find the correct password for rar, 7z, zip archives.
pkgver = 0.2
- pkgrel = 5
+ pkgrel = 6
url = http://rarcrack.sourceforge.net/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 444ebc28efa7..82a3692cc589 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=rarcrack
pkgver=0.2
-pkgrel=5
+pkgrel=6
pkgdesc="Use brute force algorithm to find the correct password for rar, 7z, zip archives."
arch=('i686' 'x86_64')
license=('GPL')
@@ -20,11 +20,15 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/ziman/$pkgname/archive/$pkg
"file-type-detection.patch")
sha256sums=('662d14f080431424c816eca11cea00fe8eeb5bf0d2da36e18f5d07140c0a78af'
'8d39315ead8f6058bc8f37b6724e7d266eed2b7ee79910de6a5a4bc2ee80bbe4')
-
-build() {
+
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
# https://github.com/optiseth/rarcrack-fix Thank you optiseth:
- patch < "$srcdir/file-type-detection.patch"
+ patch -p0 -i "$srcdir/file-type-detection.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
make
}