summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSzabolcs Sipos2021-11-18 00:57:03 +0000
committerSzabolcs Sipos2021-11-18 00:57:03 +0000
commit38bc76156e50c22d26eb98903cbd06fa77169840 (patch)
tree66316bb029339fb065ecae45f397d11664b1e1aa
downloadaur-38bc76156e50c22d26eb98903cbd06fa77169840.tar.gz
Initial commit - version: 20211029
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD22
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b84f1cebbca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = raspberrypi-devicetree-git
+ pkgdesc = Downstream devicetrees and overlays for Raspberry Pi
+ pkgver = 20211029
+ pkgrel = 1
+ url = https://github.com/raspberrypi/firmware
+ arch = any
+ license = GPL2
+ provides = raspberrypi-devicetree
+ conflicts = uboot-raspberrypi
+ conflicts = linux-raspberrypi
+ conflicts = linux-raspberrypi4
+ options = !strip
+ source = https://github.com/raspberrypi/firmware/archive/e2bab29767e51c683a312df20014e3277275b8a6.tar.gz
+ md5sums = 2f3059f26d5572126051430c8ba8198a
+
+pkgname = raspberrypi-devicetree-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3aab1d69bd97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# Except these files
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d678d279ec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Szabolcs Sipos <archur [at] balfug [dot] com>
+
+buildarch=28
+
+pkgname=raspberrypi-devicetree-git
+pkgdesc="Downstream devicetrees and overlays for Raspberry Pi"
+pkgver=20211029
+pkgrel=1
+arch=('any')
+url="https://github.com/raspberrypi/firmware"
+provides=('raspberrypi-devicetree')
+conflicts=('uboot-raspberrypi' 'linux-raspberrypi' 'linux-raspberrypi4')
+license=(GPL2)
+options=(!strip)
+_commit=e2bab29767e51c683a312df20014e3277275b8a6
+source=("https://github.com/raspberrypi/firmware/archive/${_commit}.tar.gz")
+md5sums=('2f3059f26d5572126051430c8ba8198a')
+
+package() {
+ mkdir -p "${pkgdir}"/boot
+ cp -r "${srcdir}"/firmware-${_commit}/boot/{*.dtb,overlays} "${pkgdir}"/boot
+}