summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2021-01-23 21:08:10 +0300
committerNeoTheFox2021-01-23 21:08:10 +0300
commit4f9d86ef4486f2433defa6d1a5d1d99b1cec586a (patch)
treedac3cb9624307d09af52ed01e0f96b0d1f2810d2
downloadaur-4f9d86ef4486f2433defa6d1a5d1d99b1cec586a.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6e65d9cd50e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rastertokpsl-fs-1040
+ pkgdesc = Kyocera_FS-1040 Linux driver
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/lurepheonix/rastertokpsl-fs-1040
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = custom
+ makedepends = git
+ depends = cups
+ source = git+https://github.com/lurepheonix/rastertokpsl-fs-1040.git
+ md5sums = SKIP
+
+pkgname = rastertokpsl-fs-1040
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..778268f17579
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=rastertokpsl-fs-1040
+pkgver=1.0
+pkgrel=1
+pkgdesc="Kyocera_FS-1040 Linux driver"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/lurepheonix/rastertokpsl-fs-1040"
+license=('custom')
+depends=('cups')
+makedepends=('git')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=('git+https://github.com/lurepheonix/rastertokpsl-fs-1040.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+package() {
+ cd $srcdir/$pkgname
+ mkdir -p $pkgdir/usr/share/cups/model
+ mkdir -p $pkgdir/usr/share/cups/model/Kyocera
+ install -Dm644 Kyocera_FS-1040GDI.ppd $pkgdir/usr/share/cups/model/Kyocera/Kyocera_FS-1040GDI.ppd
+ install -Dm755 rastertokpsl $pkgdir/usr/lib/cups/filter/rastertokpsl
+ install -Dm755 rastertokpsl-fixed $pkgdir/usr/lib/cups/filter/rastertokpsl-fixed
+}