summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212022-07-09 16:29:05 +0200
committera8212022-07-09 16:29:05 +0200
commit346b83ebb1bb061d8ea3f16e9f9a2e6afa2ae302 (patch)
tree35fb18d70cc3dcf41b0f4d9830da9b24ac55f9ef
parent828f19afb036050994fb3a2dab472a1a400dda45 (diff)
downloadaur-ratox-git.tar.gz
Update PKGBUILD. Use github sources
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4631be2bb56d..bb86ed96739e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Tue Dec 6 04:03:02 UTC 2016
pkgbase = ratox-git
pkgdesc = FIFO based tox client
- pkgver = 0.3.0.452
+ pkgver = 0.4.r21.g73bdc88
pkgrel = 1
- url = http://git.z3bra.org/ratox/log.html
+ url = https://github.com/pranomostro/ratox
arch = i686
arch = x86_64
license = custom
@@ -12,8 +10,7 @@ pkgbase = ratox-git
depends = toxcore
provides = ratox
conflicts = ratox
- source = ratox::git+git://git.z3bra.org/ratox
+ source = git+https://github.com/pranomostro/ratox
sha256sums = SKIP
pkgname = ratox-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 430760c0b002..fc951dbdb442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
-_pkgname=ratox
-pkgname=$_pkgname-git
-pkgver=0.3.0.452
+pkgname=ratox-git
+_pkgname=${pkgname%-git}
+pkgver=0.4.r21.g73bdc88
pkgrel=1
pkgdesc="FIFO based tox client"
arch=('i686' 'x86_64')
-url="http://git.z3bra.org/ratox/log.html"
+url="https://github.com/pranomostro/ratox"
license=('custom')
depends=('toxcore')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+git://git.z3bra.org/ratox")
+source=("git+$url")
sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
- echo $(grep "^VERSION =" config.mk | cut -d " " -f3).0.$(git rev-list --count HEAD)
+ git describe --long --tags | sed -e 's/^v//;s/-/.r/;s/-/./g'
}
build() {