summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsekret2015-06-09 20:05:49 +0200
committersekret2015-06-09 20:05:49 +0200
commitb8c2349605e3b3c44ea8638d7fa4087829daf966 (patch)
tree90535f51a126a520dca491a8b5be24dfbbdf50f7
downloadaur-b8c2349605e3b3c44ea8638d7fa4087829daf966.tar.gz
initial AUR4 import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--config.h87
3 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d03937ea8591
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ratox-git
+ pkgdesc = FIFO based tox client
+ pkgver = 0.2.1.r0.g1a84f07
+ pkgrel = 1
+ url = http://ratox.2f30.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ depends = tox-git
+ provides = ratox
+ conflicts = ratox
+ source = ratox::git+http://git.2f30.org/ratox/
+ source = config.h
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ratox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80061b7a87f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+
+_pkgname=ratox
+pkgname=$_pkgname-git
+pkgver=0.2.1.r0.g1a84f07
+pkgrel=1
+pkgdesc="FIFO based tox client"
+arch=('i686' 'x86_64')
+url="http://ratox.2f30.org"
+license=('custom')
+depends=('glibc' 'tox-git')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+http://git.2f30.org/ratox/"
+ "config.h")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ # uncomment, if you want to use your own config.h
+ #cp "$srcdir/config.h" .
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..6ec04be5ef23
--- /dev/null
+++ b/config.h
@@ -0,0 +1,87 @@
+/* See LICENSE file for copyright and license details. */
+#define DATAFILE ".ratox.data"
+/* connection delay in seconds */
+#define CONNECTDELAY 3
+/* ringing delay in seconds */
+#define RINGINGDELAY 9
+#define MAXCALLS 8
+
+static int encryptdatafile = 0;
+
+static char proxyaddr[] = "localhost";
+static uint16_t proxyport = 8080;
+
+static struct node nodes[] = {
+ {
+ .addr4 = "192.254.75.98",
+ .addr6 = "2607:5600:284::2",
+ .port = 33445,
+ .idstr = "951C88B7E75C867418ACDB5D273821372BB5BD652740BCDF623A4FA293E75D2F"
+ },
+ {
+ .addr4 = "31.7.57.236",
+ .addr6 = "2a02:29b8:1737::fee1:bad:6483:467d",
+ .port = 443,
+ .idstr = "2A4B50D1D525DA2E669592A20C327B5FAD6C7E5962DC69296F9FEC77C4436E4E"
+ },
+ {
+ .addr4 = "107.161.17.51",
+ .addr6 = "2604:180:1:57:1::",
+ .port = 33445,
+ .idstr = "7BE3951B97CA4B9ECDDA768E8C52BA19E9E2690AB584787BF4C90E04DBB75111"
+ },
+ {
+ .addr4 = "144.76.60.215",
+ .addr6 = "2a01:4f8:191:64d6::1",
+ .port = 33445,
+ .idstr = "04119E835DF3E78BACF0F84235B300546AF8B936F035185E2A8E9E0A67C8924F",
+ },
+ {
+ .addr4 = "23.226.230.47",
+ .addr6 = "2604:180:1::3ded:b280",
+ .port = 33445,
+ .idstr = "A09162D68618E742FFBCA1C2C70385E6679604B2D80EA6E84AD0996A1AC8A074"
+ },
+ {
+ .addr4 = "37.59.102.176",
+ .addr6 = "2001:41d0:51:1:0:0:0:cc",
+ .port = 33445,
+ .idstr = "B98A2CEAA6C6A2FADC2C3632D284318B60FE5375CCB41EFA081AB67F500C1B0B"
+ },
+ {
+ .addr4 = "37.187.46.132",
+ .addr6 = "2001:41d0:0052::0507",
+ .port = 33445,
+ .idstr = "5EB67C51D3FF5A9D528D242B669036ED2A30F8A60E674C45E7D43010CB2E1331"
+ },
+ {
+ .addr4 = "178.21.112.187",
+ .addr6 = "2a02:2308::216:3eff:fe82:eaef",
+ .port = 33445,
+ .idstr = "4B2C19E924972CB9B57732FB172F8A8604DE13EEDA2A6234E348983344B23057"
+ },
+ {
+ .addr4 = "192.210.149.121",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "F404ABAA1C99A9D37D61AB54898F56793E1DEF8BD46B1038B9D822E8460FAB67",
+ },
+ {
+ .addr4 = "54.199.139.199",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "7F9C31FE850E97CEFD4C4591DF93FC757C7C12549DDD55F8EEAECC34FE76C029"
+ },
+ {
+ .addr4 = "63.165.243.15",
+ .addr6 = NULL,
+ .port = 443,
+ .idstr = "8CD087E31C67568103E8C2A28653337E90E6B8EDA0D765D57C6B5172B4F1F04C"
+ },
+ {
+ .addr4 = "195.154.119.113",
+ .addr6 = "2001:bc8:3698:101::1",
+ .port = 33445,
+ .idstr = "E398A69646B8CEACA9F0B84F553726C1C49270558C57DF5F3C368F05A7D71354"
+ }
+};