summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsekret2016-01-18 18:59:02 +0100
committersekret2016-01-18 18:59:02 +0100
commite5dffa116e711630479ed90106bbcebc931d00df (patch)
tree15e147ecc7bb126ec00370a1dfd10ebd5c2480a9
parente7ca0708a9f1385c30d06d950b298085ab0a1e28 (diff)
downloadaur-e5dffa116e711630479ed90106bbcebc931d00df.tar.gz
updated config.h to upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--config.h124
3 files changed, 99 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3f0367b681a..62dc791edb3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 18 17:52:16 UTC 2016
+# Mon Jan 18 17:59:02 UTC 2016
pkgbase = ratox-git
pkgdesc = FIFO based tox client
pkgver = 0.2.1.r0.g1a84f07
- pkgrel = 2
+ pkgrel = 3
url = http://ratox.2f30.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5b79cf509ba3..b9f79f3ed0cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=ratox
pkgname=$_pkgname-git
pkgver=0.2.1.r0.g1a84f07
-pkgrel=2
+pkgrel=3
pkgdesc="FIFO based tox client"
arch=('i686' 'x86_64')
url="http://ratox.2f30.org"
diff --git a/config.h b/config.h
index 6ec04be5ef23..a1498f3d557d 100644
--- a/config.h
+++ b/config.h
@@ -1,87 +1,155 @@
/* See LICENSE file for copyright and license details. */
-#define DATAFILE ".ratox.data"
-/* connection delay in seconds */
+
+/* Connection delay in seconds */
#define CONNECTDELAY 3
-/* ringing delay in seconds */
-#define RINGINGDELAY 9
+
+/* Ringing delay in seconds */
+#define RINGINGDELAY 16
+
+/* Maximum number of simultaneous calls */
#define MAXCALLS 8
-static int encryptdatafile = 0;
+static char *savefile = ".ratox.tox";
+static int encryptsavefile = 0;
-static char proxyaddr[] = "localhost";
-static uint16_t proxyport = 8080;
+static int ipv6 = 0;
+static int tcp = 0;
+static int proxy = 0;
+static int proxytype = 2; /* 1 = HTTP, 2 = SOCKS5 */
+static char proxyaddr[] = "localhost";
+static uint16_t proxyport = 8080;
static struct node nodes[] = {
{
.addr4 = "192.254.75.98",
.addr6 = "2607:5600:284::2",
- .port = 33445,
+ .port = 33445,
.idstr = "951C88B7E75C867418ACDB5D273821372BB5BD652740BCDF623A4FA293E75D2F"
},
{
.addr4 = "31.7.57.236",
.addr6 = "2a02:29b8:1737::fee1:bad:6483:467d",
- .port = 443,
+ .port = 443,
.idstr = "2A4B50D1D525DA2E669592A20C327B5FAD6C7E5962DC69296F9FEC77C4436E4E"
},
{
.addr4 = "107.161.17.51",
.addr6 = "2604:180:1:57:1::",
- .port = 33445,
+ .port = 33445,
.idstr = "7BE3951B97CA4B9ECDDA768E8C52BA19E9E2690AB584787BF4C90E04DBB75111"
},
{
.addr4 = "144.76.60.215",
.addr6 = "2a01:4f8:191:64d6::1",
- .port = 33445,
- .idstr = "04119E835DF3E78BACF0F84235B300546AF8B936F035185E2A8E9E0A67C8924F",
+ .port = 33445,
+ .idstr = "04119E835DF3E78BACF0F84235B300546AF8B936F035185E2A8E9E0A67C8924F"
},
{
.addr4 = "23.226.230.47",
.addr6 = "2604:180:1::3ded:b280",
- .port = 33445,
+ .port = 33445,
.idstr = "A09162D68618E742FFBCA1C2C70385E6679604B2D80EA6E84AD0996A1AC8A074"
},
{
- .addr4 = "37.59.102.176",
- .addr6 = "2001:41d0:51:1:0:0:0:cc",
- .port = 33445,
- .idstr = "B98A2CEAA6C6A2FADC2C3632D284318B60FE5375CCB41EFA081AB67F500C1B0B"
+ .addr4 = "178.62.125.224",
+ .addr6 = "2a03:b0c0:1:d0::178:6001",
+ .port = 33445,
+ .idstr = "10B20C49ACBD968D7C80F2E8438F92EA51F189F4E70CFBBB2C2C8C799E97F03E"
},
{
.addr4 = "37.187.46.132",
.addr6 = "2001:41d0:0052::0507",
- .port = 33445,
+ .port = 33445,
.idstr = "5EB67C51D3FF5A9D528D242B669036ED2A30F8A60E674C45E7D43010CB2E1331"
},
{
.addr4 = "178.21.112.187",
.addr6 = "2a02:2308::216:3eff:fe82:eaef",
- .port = 33445,
+ .port = 33445,
.idstr = "4B2C19E924972CB9B57732FB172F8A8604DE13EEDA2A6234E348983344B23057"
},
{
+ .addr4 = "128.199.237.51",
+ .addr6 = "2400:6180:0:d0::1ba:7001",
+ .port = 33445,
+ .idstr = "67D80D1E00DE2A5294C9CCF9116C72CEC05FB8C2C6DBCEE0B5EB796DA52E2564"
+ },
+ {
+ .addr4 = "195.154.119.113",
+ .addr6 = "2001:bc8:3698:101::1",
+ .port = 33445,
+ .idstr = "E398A69646B8CEACA9F0B84F553726C1C49270558C57DF5F3C368F05A7D71354"
+ },
+ {
+ .addr4 = "178.62.250.138",
+ .addr6 = "2a03:b0c0:2:d0::16:1",
+ .port = 33445,
+ .idstr = "788236D34978D1D5BD822F0A5BEBD2C53C64CC31CD3149350EE27D4D9A2F9B6B"
+ },
+ {
+ .addr4 = "178.62.150.106",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "58D2DE4B169502669941E50780C1630FAA48A0B7026D6F4066C320D47AC6401E"
+ },
+ {
.addr4 = "192.210.149.121",
.addr6 = NULL,
- .port = 33445,
- .idstr = "F404ABAA1C99A9D37D61AB54898F56793E1DEF8BD46B1038B9D822E8460FAB67",
+ .port = 33445,
+ .idstr = "F404ABAA1C99A9D37D61AB54898F56793E1DEF8BD46B1038B9D822E8460FAB67"
},
{
.addr4 = "54.199.139.199",
.addr6 = NULL,
- .port = 33445,
+ .port = 33445,
.idstr = "7F9C31FE850E97CEFD4C4591DF93FC757C7C12549DDD55F8EEAECC34FE76C029"
},
{
.addr4 = "63.165.243.15",
.addr6 = NULL,
- .port = 443,
+ .port = 443,
.idstr = "8CD087E31C67568103E8C2A28653337E90E6B8EDA0D765D57C6B5172B4F1F04C"
},
{
- .addr4 = "195.154.119.113",
- .addr6 = "2001:bc8:3698:101::1",
- .port = 33445,
- .idstr = "E398A69646B8CEACA9F0B84F553726C1C49270558C57DF5F3C368F05A7D71354"
- }
+ .addr4 = "76.191.23.96",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "93574A3FAB7D612FEA29FD8D67D3DD10DFD07A075A5D62E8AF3DD9F5D0932E11"
+ },
+ {
+ .addr4 = "46.38.239.179",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "F5A1A38EFB6BD3C2C8AF8B10D85F0F89E931704D349F1D0720C3C4059AF2440A"
+ },
+ {
+ .addr4 = "144.76.93.230",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "2C308B4518862740AD9A121598BCA7713AFB25858B747313A4D073E2F6AC506C"
+ },
+ {
+ .addr4 = "78.225.128.39",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "7A2306BFBA665E5480AE59B31E116BE9C04DCEFE04D9FE25082316FA34B4DA0C"
+ },
+ {
+ .addr4 = "195.154.109.148",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "391C96CB67AE893D4782B8E4495EB9D89CF1031F48460C06075AA8CE76D50A21"
+ },
+ {
+ .addr4 = "192.3.173.88",
+ .addr6 = NULL,
+ .port = 33445,
+ .idstr = "3E1FFDEB667BFF549F619EC6737834762124F50A89C8D0DBF1DDF64A2DD6CD1B"
+ },
+ {
+ .addr4 = "130.133.110.14",
+ .addr6 = "2001:6f8:1c3c:babe::14:1",
+ .port = 33445,
+ .idstr = "461FA3776EF0FA655F1A05477DF1B3B614F7D6B124F7DB1DD4FE3C08B03B640F"
+ },
};