summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroda2016-08-11 15:54:57 +0900
committeroda2016-08-11 15:54:57 +0900
commitfb79ae8ce1f4093a15451fb97bdbe41955e53dcd (patch)
treec00f5a08fdd788a900f40a179c4922ade922986f
downloadaur-fb79ae8ce1f4093a15451fb97bdbe41955e53dcd.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
-rw-r--r--ratpoison.desktop8
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d622dba0b315
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ratpoison-jcs-git
+ pkgdesc = hacks atop the official ratpoison
+ pkgver = 1.4.8
+ pkgrel = 1
+ url = https://github.com/jcs/ratpoison
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxinerama
+ depends = readline
+ depends = bash
+ depends = perl
+ depends = libxtst
+ depends = libxft
+ depends = texinfo
+ conflicts = ratpoison
+ source = ratpoison::git://github.com/jcs/ratpoison.git#branch=master
+ source = ratpoison.desktop
+ md5sums = SKIP
+ md5sums = 29c3cb9be59758e39d8471391231a74a
+
+pkgname = ratpoison-jcs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec3cfad8b616
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Oda Kenta <oda.kenta.hj@gmail.com>
+
+pkgname=ratpoison-jcs-git
+_pkgname="${pkgname%%-*}"
+pkgver=1.4.8
+pkgrel=1
+pkgdesc="hacks atop the official ratpoison"
+conflicts=('ratpoison')
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libxinerama' 'readline' 'bash' 'perl' 'libxtst' 'libxft' 'texinfo')
+url="https://github.com/jcs/ratpoison"
+source=("${_pkgname}"::"git://github.com/jcs/ratpoison.git#branch=master"
+ "${_pkgname}.desktop")
+md5sums=('SKIP'
+ '29c3cb9be59758e39d8471391231a74a')
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ # FS#38726, v1.4.6-2
+ sed -i 's|PRINT_ERROR (("XGetWMName|PRINT_DEBUG (("XGetWMName|' src/manage.c
+
+ ./configure --prefix=/usr
+ make CFLAGS="$CFLAGS -DHAVE_GETLINE"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ # fix permissions
+ chmod a+x "${pkgdir}/usr/share/ratpoison/"{allwindows.sh,clickframe.pl,rpshowall.sh,rpws,split.sh}
+
+ # Not useful outside the source tree.
+ rm "${pkgdir}/usr/share/ratpoison/genrpbindings"
+
+ cd contrib
+ ./genrpbindings
+ install -dm755 "${pkgdir}/usr/share/ratpoison/bindings"
+ install -m644 {Ratpoison.pm,ratpoison-cmd.el,ratpoison.rb,ratpoison.lisp,ratpoison.py} \
+ "${pkgdir}/usr/share/ratpoison/bindings/"
+
+ install -dm755 "${pkgdir}/usr/share/emacs/site-lisp"
+ install -m644 ratpoison.el \
+ "${pkgdir}/usr/share/emacs/site-lisp/"
+
+ rm "${pkgdir}/usr/share/ratpoison/ratpoison.el"
+
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/etc/X11/sessions/${_pkgname}.desktop"
+}
diff --git a/ratpoison.desktop b/ratpoison.desktop
new file mode 100644
index 000000000000..9e29bd46a2e8
--- /dev/null
+++ b/ratpoison.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Ratpoison
+Comment=The ratpoison window manager
+Exec=ratpoison
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application